Problems loading ipmi_si on Poweredge 750

Richard Halfpenny richard.halfpenny at exa-networks.co.uk
Mon Jan 29 05:21:32 CST 2007


Hi,

I'm trying to get kernel module ipmi_si loaded to be able to use OMSA on a Poweredge 750 
but no joy :(

Kernel is 2.6.17-5mdv on Mandriva 2007.

The docs on http://linux.dell.com/ipmi.shtml indicate the hardware is SMIC so I have tried:

# modprobe -v ipmi_si type=smic
insmod /lib/modules/2.6.17-5mdv/kernel/drivers/char/ipmi/ipmi_si.ko.gz type=smic
FATAL: Error inserting ipmi_si 
(/lib/modules/2.6.17-5mdv/kernel/drivers/char/ipmi/ipmi_si.ko.gz): No such device


lspci -vv shows:

00:1f.3 SMBus: Intel Corp. 6300ESB SMBus Controller (rev 02)
         Subsystem: Dell: Unknown device 0165
         Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- 
ParErr-Stepping-SERR-FastB2B-
         Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- 
<MAbort- >SERR- <PERR-
         Interrupt: pin B routed to IRQ 17
         Region 4: I/O ports at 08c0 [size=32]

So i would assume modprobe ipmi_si type=smic ports=0x8c0 but this just hangs for a few 
minutes and returns the following in dmesg:

IPMI System Interface driver.
ipmi_si: Trying hardcoded-specified SMIC state machine at I/O address 0x8c0, slave address 
0x0, irq 0
ipmi_smic_drv: smic hosed: smic timed out.
ipmi_si: There appears to be no BMC at this location
ipmi_si: Unable to find any System Interface(s)


Is it the kernel version or module parameters that I have incorrect?

Kind regards,
Richard.

-- 
Network Operations
Exa Networks Ltd :: AS30740
richard.halfpenny at exa-networks.co.uk



More information about the Linux-PowerEdge mailing list