MegaRaid SAS CLI question

Shane Williams broot at ischool.utexas.edu
Thu Jan 4 14:06:29 CST 2007


On Wed, 3 Jan 2007, Joe Malicki wrote:

> Shane Williams wrote:
> > We've got a PE 2950 (running vmware 3) with a failed drive, which I
> > pulled out and reseated (as instructed by Dell tech support). I've
> > downloaded the MegaCLI tool for the Perc5, and using the -PDList
> > command I can see that the disk in question is now rebuilding.  It
> > looks like I should be able to use the -PDRbld command to get more
> > details on the progress of the rebuild, but I'm having trouble with
> > the option syntax (and the Dell tech was as stumped as I was).
> > 
> > Specifically, I run into trouble with the -PhysDrv arguments. When I
> > run: 
> > 
> > MegaCli -PDRbld -ProgDsply -PhysDrv E0:S3 -a0
> > 
> > it says: "Invalid input at or near token E".  I've tried it with
> > brackets around the E0:S3, brackets in quotes, and several other
> > variations, but no matter what I do, it gives the same error.
> > So, can someone tell me what the proper command looks like, or what
> > other command I can use to get more information about the rebuild
> > process?
> > 
> > Needless to say, I'm not real impressed with the docs that LSI
> > provides (the text or pdf versions).
> > 
> Agreed.  Syntax is probably:
> 
> MegaCli -PDRbld -ProgDsply -PhysDrv [1:3] -a0
> 
> (first enclosure is 1 for me), also check whether or not your drives are
> 1 or 0 based for this command (I believe enclosures are 1 based, and
> drives 0 based, iirc).
> 
> It took us some time to figure that one out as well.

That did it, thanks.  I never would have reasoned that out based on the
Readme file, so you saved me a lot of time and frustration trying to
guess what input they were expecting.

-- 
Public key 0x87D001E0 at           |                 Shane Williams
http://pgp.mit.edu/                |      System Admin - UT iSchool
=----------------------------------+-------------------------------
All syllogisms contain three lines |       broot at ischool.utexas.edu
Therefore this is not a syllogism  | www.ischool.utexas.edu/~shanew



More information about the Linux-PowerEdge mailing list