MegaRaid SAS CLI question

Shane Williams broot at ischool.utexas.edu
Wed Jan 3 17:13:52 CST 2007


We've got a PE 2950 (running vmware 3) with a failed drive, which I
pulled out and reseated (as instructed by Dell tech support). I've
downloaded the MegaCLI tool for the Perc5, and using the -PDList
command I can see that the disk in question is now rebuilding.  It
looks like I should be able to use the -PDRbld command to get more
details on the progress of the rebuild, but I'm having trouble with
the option syntax (and the Dell tech was as stumped as I was).

Specifically, I run into trouble with the -PhysDrv arguments. When I
run: 

MegaCli -PDRbld -ProgDsply -PhysDrv E0:S3 -a0

it says: "Invalid input at or near token E".  I've tried it with
brackets around the E0:S3, brackets in quotes, and several other
variations, but no matter what I do, it gives the same error.
So, can someone tell me what the proper command looks like, or what
other command I can use to get more information about the rebuild
process?

Needless to say, I'm not real impressed with the docs that LSI
provides (the text or pdf versions).

-- 
Public key 0x87D001E0 at           |                 Shane Williams
http://pgp.mit.edu/                |      System Admin - UT iSchool
=----------------------------------+-------------------------------
All syllogisms contain three lines |       broot at ischool.utexas.edu
Therefore this is not a syllogism  | www.ischool.utexas.edu/~shanew



More information about the Linux-PowerEdge mailing list