2nd Try: Openmanage on 2400 with FC3

Morgan Toal mtoal at burlingtoniowa.org
Tue Jan 2 14:07:30 CST 2007


Wanted to try again after the holidays.

Thanks to anyone who might be able to provide some insight.

Morgan Toal




-------- Original Message --------
Subject: Openmanage on 2400 with FC3
Date: Thu, 28 Dec 2006 13:23:34 -0600
From: Morgan Toal <mtoal at burlingtoniowa.org>
To: linux-poweredge at dell.com

Hi folks,

I'm having some troubles getting Openmanage to work as I expect it to on
my PowerEdge 2400 system.

Specifically, I am trying to install:
OMI-SrvAdmin-Dell-Web-LX-450-32-335_A00.tar.gz

I am running Fedora Core 3, with kernel version kernel-2.6.9-1.667.

I have installed jdk-1.5.0_09-fcs, along with jpackage.org
java-1.5.0-sun-compat-1.5.0.09-1jpp

The srvadmin-install.sh installer script works OK, and everything seems
to install correctly. I am installing CLI, web server, diagnostic, and
storage management. I am not installing remote access.

What seems to be happening is that omawsd runs for about 5 seconds and
then dies, leaving it's pid file behind, and I am not sure why.

I can only conclude that the "status(-2)" refers to the unexpected
presence of the pid file in /var/run. Blow it away and it starts, but
dies after about 5 seconds.

If I hit https://pd1:1311 in this several second window, I do get a
certificate message.

The SCSI parity error seems like it happens when the process dies, but I
don't really get why these would be related.

[root at pd1 run]# rm omaws32.pid
rm: remove regular file `omaws32.pid'? y
[root at pd1 run]# service omasd status
omasd: unrecognized service
[root at pd1 run]# service omawsd status
omaws32 is stopped
[root at pd1 run]# service omawsd start
Starting Secure Port Server:                               [  OK  ]
[root at pd1 run]# service omawsd status
omaws32 (pid 27612 27611) is running...
[root at pd1 run]# service omawsd status
omaws32 (pid 27612 27611) is running...
[root at pd1 run]# service omawsd status
omaws32 dead but pid file exists
[root at pd1 run]# service omawsd start
Starting Secure Port Server: status(-2)                    [FAILED]

[root at pd1 run]# tail /var/log/messages
Dec 28 10:23:34 pd1 omawsd: omaws32 startup failed
Dec 28 10:23:38 pd1 dhcpd: Wrote 86 leases to leases file.
Dec 28 10:23:38 pd1 dhcpd: DHCPREQUEST for 192.168.1.116 from
00:08:74:b5:2e:a4 (seint01) via eth0
Dec 28 10:23:38 pd1 dhcpd: DHCPACK on 192.168.1.116 to 00:08:74:b5:2e:a4
(seint01) via eth0
Dec 28 10:24:01 pd1 omawsd: omaws32 startup succeeded
Dec 28 10:24:10 pd1 kernel: sym0: SCSI parity error detected: SCR1=132
DBC=50000000 SBCL=0
Dec 28 10:26:02 pd1 omawsd: omaws32 startup succeeded
Dec 28 10:26:10 pd1 kernel: sym0: SCSI parity error detected: SCR1=132
DBC=50000000 SBCL=0
Dec 28 10:26:41 pd1 omaws32: status(-2)
Dec 28 10:26:41 pd1 omawsd: omaws32 startup failed


-- 
Morgan Toal, CFCE, RHCE, CEH
Network Manager
City of Burlington, Iowa
319-759-8882

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq


-- 
Morgan Toal, CFCE, RHCE, CEH
Network Manager
City of Burlington, Iowa
319-759-8882

-- 
Morgan Toal, CFCE, RHCE, CEH
Network Manager
City of Burlington, Iowa
319-759-8882



More information about the Linux-PowerEdge mailing list