Installing OMSA on CentOS 4.4?

Rev. Jeffrey Paul sneak at datavibe.net
Tue Dec 26 16:06:51 CST 2006


Hi.  I've a new Poweredge and I'm trying to put OMSA on it.  Operating
under the impression that CentOS 4.4 and RHEL 4 should be identical in
everything except name and the understanding that OMSA kinda
unofficially supports CentOS (due to the first fact), I was suprised to
find that it gave me an 'Unsupported system' error.

[root at boxname supportscripts]# ./srvadmin-install.sh
  Unsupported system (sysid=01EB)
[root at boxname supportscripts]# pwd
/srvadmin/linux/supportscripts
[root at boxname supportscripts]# cat /etc/redhat-release
CentOS release 4.4 (Final)
[root at boxname supportscripts]#

When I try with the yum repo:

Running Transaction
srvadmin-deng: not supported on this system (sysid=01EB)
error: %pre(srvadmin-deng-5.0.0-463.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping srvadmin-deng-5.0.0-463
srvadmin-omacore:
Missing file information! This rpm, "srvadmin-omacore", depends on
version "5.0.0" of "srvadmin-deng" being installed.
The file, "/etc/omreg.cfg", does not contain the required "srvadmin-deng"
version information needed by this rpm to install.
This indicates that the required version of "srvadmin-deng" is
not installed. This rpm has not been installed.
error: %pre(srvadmin-omacore-5.0.0-463.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping srvadmin-omacore-5.0.0-463
srvadmin-odf:
Missing file information! This rpm, "srvadmin-odf", depends on
version "5.0.0" of "srvadmin-omacore" being installed.
The file, "/etc/omreg.cfg", does not contain the required "srvadmin-omacore"
version information needed by this rpm to install.
This indicates that the required version of "srvadmin-omacore" is
not installed. This rpm has not been installed.
error: %pre(srvadmin-odf-5.0.0-463.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping srvadmin-odf-5.0.0-463
srvadmin-storage:
Missing file information! This rpm, "srvadmin-storage", depends on
version "5.0.0" of "srvadmin-omacore" being installed.
The file, "/etc/omreg.cfg", does not contain the required "srvadmin-omacore"
version information needed by this rpm to install.
This indicates that the required version of "srvadmin-omacore" is
not installed. This rpm has not been installed.
error: %pre(srvadmin-storage-5.0.0-463.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping srvadmin-storage-5.0.0-463
  Installing: srvadmin-all                 ######################### [5/5]


Is there a special hack needed to make it think it's on RedHat?

-j

-- 
--------------------------------------------------------
 Rev. Jeffrey Paul    -datavibe-     sneak at datavibe.net
  aim:x736e65616b   pgp:0xD9B3C17D   phone:877-748-3467
   9440 0C7F C598 01CA 2F17  D098 0A3A 4B8F D9B3 C17D
--------------------------------------------------------



More information about the Linux-PowerEdge mailing list