PERC RAID5 broken

Petr Vyhnal vyhnal at cns.eu
Tue Dec 19 03:49:00 CST 2006


Hi all,

yesterday I found degraded RAID5 on one Dell box with Debian. It's
PowerEdge SC1420 with three SATA HDDs on PERC 320/DC controller. I used
afacli to rescan controller, than I removed dead_partition but I cannot
assign redetected drive to my array. Does anybody have some tip how to
re-assign HDD and rebuild array?

Log from afacli:

mail:~# afacli
-------------------------------------------------------------------------------------------------------------------------------------------------------------

DELL PowerEdge Expandable RAID Controller 2 Command Line Interface
Copyright 1998-2002 Adaptec, Inc. All rights reserved
-------------------------------------------------------------------------------------------------------------------------------------------------------------


FASTCMD> open afa0
Executing: open "afa0"

AFA0> disk list
Executing: disk list

B:ID:L  Device Type     Blocks    Bytes/Block Usage            Shared
Rate
------  --------------  --------- ----------- ---------------- ------
----
0:00:0   Disk            585937500 512         Initialized      NO
320
0:01:0   Disk            585937500 512         Initialized      NO
320
0:02:0   Disk            585937500 512         Initialized      NO
320

AFA0> container list
Executing: container list
Num          Total  Oth Chunk          Scsi   Partition
Label Type   Size   Ctr Size   Usage   B:ID:L Offset:Size
----- ------ ------ --- ------ ------- ------ -------------
0    RAID-5  558GB       64KB Valid   0:00:0 64.0KB: 279GB
/dev/sda             ARRAY0           0:01:0 64.0KB: 279GB
                                        --- Missing ---


AFA0>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20061219/8f534c82/attachment.htm 


More information about the Linux-PowerEdge mailing list