megaraid_sas waiting for command and then offline

David Gwynne dlg at itee.uq.edu.au
Tue Dec 12 00:50:20 CST 2006


On 12/12/2006, at 3:58 PM, Joseph Malicki wrote:

>
>>
> Hi Dave,

Hey Joseph,

> Thanks for the quick response, it's good to know we're not alone.   
> Do you have a workload that you know reproduces it (we haven't been  
> able to find one thus far, though the different configuration may  
> be related).  What hardware are you running, if we can narrow this  
> down (beyond mentioned above):

I am doing the development on a Dell PowerEdge 2850 with a single P4  
Xeon at 3.2GHz. It is capable of doing hyperthreading, but I have  
that disabled. I'll have to poke around to get a more specific model  
number.

I've also tried my driver on a Sun Ultra 20 Workstation, and I was  
still able to reproduce the problem. That tells to me that it is a  
problem with my driver, or with the hba itself.

However, because I'm able to do really large amounts of io on the  
controller before the issue happens, I'm inclined to rule out my  
driver. Especially now that someone is reporting similar problems on  
linux, I'm really starting to lean toward a problem with the HBA itself.

> 1. Are you running SMP/what chips? (we have dual Woodcrest 5160,  
> which are both dual core chips)

As stated above, just a uniprocessor p4 Xeon.

> 2. How much RAM do you have (which may implicate or exonerate any  
> issues with DMA >8GB)?  (we're running 16GB)

Uhm... 4GB according to prtconf.

> 3.Which PERC 5/E firmware/package version are you running? (we have  
> been using 5.0.1-0003 when we've seen the problems)  does  
> 5.0.2-0003 help?

I've been running with 5.0.2-0003 for about a week and a half now,  
with no improvement. I tried this firmware on both the 2850 and the  
ultra 20.

> I've only ever accessed patrol read etc. settings through the  
> MegaCli utility for Linux, so I'm not sure if you can through the  
> BIOS (though I would assume so?).
>

> Are you running the firmware below, or the 5.0.1-0003 version?

5.0.2-0003

>
> Thanks!

I hope this helps, but I know it is going to be difficult to use my  
experiences as a datapoint since I'm running a completely unsupported  
configuration.

dlg

> Joe
>>>
>>> Brett, is this still happening to you?  We're seeing this very
>>> sporadically, but it does concern us.  We've seen driver updates in
>>> 2.6.19 (v00.00.03.05) and a new Dell PERC 5/i firmware:
>>>
>>> Package Version - 5.0.2-0003
>>> Firmware Version - 1.00.01-0157
>>> SASBIOS Version - MT23
>>> Ctrl-R Version - 1.02-007
>>> MPT Version - 00.06.71.00-IT
>>>
>>>
>
>



More information about the Linux-PowerEdge mailing list