OMSA support for Debian

Brian E. Seppanen seppy at chartermi.net
Fri Dec 1 07:52:19 CST 2006


I have a debian sarge system that I just compiled 2.6.18 for.    I 
included the mainline dcdbas driver.   What other steps would be required 
to get the other drivers necessary for providing the omsa support?

Is there a howto somewhere.   Using Paul Bordulin's omsa-drivers-4.4 
source to compile the drivers for 2.6.18, i get errors similar to the 
following

   CC [M]  /usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcddks.o
/usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcddks.c: In function 
`esm_verify_area_write':
/usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcddks.c:575: warning: 
implicit declaration of function `verify_area'
   LD [M]  /usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcdesm.o
   Building modules, stage 2.
   MODPOST
WARNING: "verify_area" 
[/usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcdesm.ko] undefined!
   CC      /usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcdesm.mod.o
   LD [M]  /usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcdesm.ko
make: Leaving directory `/usr/src/linux-2.6.18'
make: Entering directory `/usr/src/linux-2.6.18'
   INSTALL /usr/src/omsa-driver-4.4/buildtmp.4400/dcdesm/dcdesm.ko
   DEPMOD  2.6.18
WARNING: /lib/modules/2.6.18/extra/dcdtvm.ko needs unknown symbol 
verify_area
WARNING: /lib/modules/2.6.18/extra/dcdipm.ko needs unknown symbol 
verify_area
WARNING: /lib/modules/2.6.18/extra/dcdesm.ko needs unknown symbol 
verify_area
WARNING: /lib/modules/2.6.18/extra/dcdbas.ko needs unknown symbol 
verify_area
make: Leaving directory `/usr/src/linux-2.6.18'
make: Entering directory `/usr/src/linux-2.6.18'

its been a long time, since I've delved into getting omsa working on 
debian, so have mercy...

Thanks,



More information about the Linux-PowerEdge mailing list