kernel 2.6xx and poweredge 1750

Dan Pritts danno at internet2.edu
Fri Apr 28 15:20:17 CDT 2006


On Thu, Apr 27, 2006 at 03:02:54PM +0200, Antonin Hily wrote:
> sorry for my bad english, but i'm french... ;-)

Your english is better than my french ;)

> I've got 8 PE1750
> All are running under Debian Woody, with a 2.4xx kernel.
> I want to upgrade my kernel to 2.6xx but i know there are some problems 
> with drivers (LSI, ADAPTEC, BROADCOM...)

I think the problem you might be having is that Debian's policy forbids
inclusion of these drivers in the debian kernel image due to them not
being "Free" enough.  All the drivers that I think you could need are in
the stock kernel.org kernel.  Certainly all the drivers that *I* need
are in the stock kernel.  I don't think I have any adaptec hardware in
my 1750s, but I think i included all the adaptec scsi and raid drivers
since I use the same kernel image on other machines.

I'm running a poweredge 1750 with debian sarge with a 2.6.16.2 kernel.
I just built this the other day.

My config and a kernel .deb are at 
 http://people.internet2.edu/~danno/debian-1750

I used "kernel-package" to create this .deb.  I found some instructions
at:
  http://wiki.osuosl.org/display/LNX/Building+a+Custom+Linux+Kernel

I'm happy to make this available with no support and no promises
that it will be updated with new kernel revisions, and no promises
that I'll leave it there forever.  
 
I don't know debian very well so i don't know if my sarge .deb will
work properly on your woody system.   Also note that I use grub
on my systems - I don't know if the kernel .deb will work with lilo.


danno
--
dan pritts - systems administrator - internet2
734/352-4953 office        734/834-7224 mobile



More information about the Linux-PowerEdge mailing list