Problem with bios A02 for PE2800 and grub

Christopher McCrory chrismcc at pricegrabber.com
Sun Mar 20 14:19:01 CST 2005


Hello...

On Wed, 2005-03-09 at 07:39 -0600, Matt Domsch wrote:
> On Wed, Mar 09, 2005 at 02:24:27PM +0100, Marc Cousin wrote:
> > Hi,
> > 
> > We received a bunch of PE2800 equipped with the new A02 bios.
> > Since then, typing grub-install makes grub segfault. Of course, leaving the 
> > system not bootable ...
> > 
> > When downgrading the bios to A01, the problem totally disappears...
> > 
> > This is a very important problem to me, as we're using a mondo cd to install 
> > our servers, with a grub-install as one of the steps, and it means we cannot 
> > install a server with A02 bios.
> > 
> > Is somebody aware of this problem ?
> 
> Sounds like NX is biting you.  We haven't seen this on RHEL[34] or
> SLES9 though.
> 
> http://www.x86-64.org/lists/discuss/msg06305.html
> 
> says use noexec=off (and from the description, noexec32=off should be
> necessary too) kernel command line parameters.
> 

I ran into this today also.  (ML archives rock :)
(re)booting with noexec=off let this work


[root at lab.test root]# uname -r
2.4.21-27.0.2.ELsmp

cat /etc/redhat-release
Red Hat Enterprise Linux WS release 3 (Taroon Update 4)


NOTE: software raid

[root at lab.test root]# df /boot/
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md0                 62093     15756     43131  27% /boot

/sbin/mdadm -D /dev/md0
    Number   Major   Minor   RaidDevice State
       0       8        1        0      active sync   /dev/sda1
       1       8       17        1      active sync   /dev/sdb1



[root at lab.test root]# cat installmd1grub.sh
#!/bin/bash

grub --batch <<EOF
rootnoverify (hd0,0)
setup (hd0)
device (hd0) /dev/sdb
rootnoverify (hd0,0)
setup (hd0)
device (hd0) /dev/sda
rootnoverify (hd0,0)
EOF


[root at lab.test root]# ./installmd1grub.sh
Probing devices to guess BIOS drives. This may take a long time.


    GRUB  version 0.93  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the
possible
   completions of a device/filename.]
grub> rootnoverify (hd0,0)
grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... yes
 Checking if "/grub/stage2" exists... yes
 Checking if "/grub/e2fs_stage1_5" exists... yes
 Running "embed /grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
succeeded
./installmd1grub.sh: line 11:   838 Segmentation fault      grub --batch
<<EOF
rootnoverify (hd0,0)
setup (hd0)
device (hd0) /dev/sdb
rootnoverify (hd0,0)
setup (hd0)
device (hd0) /dev/sda
rootnoverify (hd0,0)
EOF


from dmidecode:
        System Information
                Manufacturer: Dell Computer Corporation
                Product Name: PowerEdge 1850
	Version: A02
	
Family: Xeon
                Manufacturer: Intel
                ID: 41 0F 00 00 FF FB EB BF
                Signature: Type 0, Family F, Model 4, Stepping 1

               External Clock: 800 MHz
                Max Speed: 3600 MHz
                Current Speed: 3600 MHz



-- 
Christopher McCrory
 "The^W One of the guys that keeps the servers running"

chrismcc at pricegrabber.com
 http://www.pricegrabber.com

Let's face it, there's no Hollow Earth, no robots, and
no 'mute rays.' And even if there were, waxed paper is
no defense.  I tried it.  Only tinfoil works.




More information about the Linux-PowerEdge mailing list