HELP: dell hardware monitoring with net-snmp?

Anil Sehdev anils at eu.citrix.com
Mon Mar 14 08:23:55 CST 2005


Hi please can you help!

 

Description of problem:

My problem is related to monitoring Dell hardware via SNMP (and in
particular using the dell SNMP mib) - I am using net-snmp.  This is what
I have done so far:

 

I have downloaded the Dell_10892.txt mib file and stored it in
/usr/share/snmp/mibs on my linux box.  I have got a Dell prestige (model
2650) server - with Dell Server Assistant and OpenManage software
installed on there.  My OS on this server is win2k.  I have enabled the
Microsoft SNMP service (into which I have typed the ip address of my
network management system).  Now when I run the command

 

snmpwalk -v 2c -m ALL -c public -OT <ip address of dell 2650 server> OR 

snmpwalk -v 2c -m ALL -c public -OT <ip address of dell 2650 server>
iso.org.dod.internet.private.enterprises.dell

 

I can retrieve information related to various mibs including the DELL
one.  However I also have a DELL desktop (model 360) running a Linux OS
(fedora core 2).  As far as I know there isn't any software which I can
install on here (i.e something like OpenManage - which i believe is just
for servers).  Unless there is something I have to configure in relation
to SNMP in the system BIOS.  All I have done on this machine is place
the "MIB-Dell-10892" mib file in /usr/share/snmp/mibs the permissions
for this file are -rw-r--r--  1 root root 559936 Mar 13 20:05
MIB-Dell-10892.

 

Now when I run the same command as before:

 

snmpwalk -v 2c -m ALL -c public -OT <ip address of dell 370 machine>
iso.org.dod.internet.private.enterprises.dell 

 

I get the following error: "MIB-Dell-10892::dell = No Such Object
available on this agent at this OID".

 

************************************************************************
******

Description of any troubleshooting steps you have taken 

(e.g. "I have tried the monitor on another computer.")

 

 

I have tried deleting the first few lines of the file so that it begins
with:

 

MIB-Dell-10892 DEFINITIONS ::= BEGIN

IMPORTS 

 

I have also tried the following commands now (on the precision
workstation) but still not getting any results:

 

COMMAND: snmpwalk -v1 -c public <hostname> 1.3.6.1.4.1.674.10892

OUTPUT: nothing is returned

 

COMMAND: snmpwalk -v2c public <hostname> 1.3.6.1.4.1.674.10892

OUTPUT: SNMPv2-SMI::enterprises.674.10892 = No Such Object available on
this agent at this OID

 

NOTICE: when I use "-v1" I get no error message, however when I use
"-v2c" I get no such object....

 

COMMAND: snmpwalk -v2c -c public -m ALL <hostname> 1.3.6.1.4.1.674.10892

OUTPUT: MIB-Dell-10892::server3 = No Such Object available on this agent
at this OID

 

The -OT was to specify the kind of output you want, in this case "print
human-readable text along with hex strings".  I thought I'd also try
running the command with -m ALL (so that it would read ALL the mibs).
You can see the output I receive above...it is different to the previous
two commands.

 

Any ideas on what is going on?

 

Please could you help me solve this problem!  All I want to do is
monitor the hardware on these machines and receive SNMP traps from them
when a hard drive or fan breaks for example.  I thought SNMP was the
best way to monitor this kind of thing...BUT now I'm having my doubts
because it just seems way too difficult.

 

I hope I have provided sufficient information to illustrate what I am
trying to do and really do hope you can help me! - setting up SNMP (and
SNMP Traps in particular) is something which I really need to get
working on our systems.

 

I look forward to your reply...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20050314/4661f46e/attachment.htm


More information about the Linux-PowerEdge mailing list