problem with ERA/O on PE1750 with 2.6 kernels

Sander Klein roedie at roedie.nl
Sat Mar 12 13:18:43 CST 2005


Hi,

I read on another thread on this mailinglist that adding i8042.dumbkbd=1 
to the kernel command line fixes the problem.

I tried it but I now have problems with the keyboard repeat rate. So, 
typing 'root' at the login prompt becomes 
'rrrrrrrrrooooooooooooooooottttt' or something like that ;-)

Maybe you have more luck.

Greets,

Sander Klein

Martin Bonner wrote:
> Hi,
> 
> I'm running debian on a PE1750 with integrated RAC. When booting stock
> debian kernel 2.4.27-2-686-smp the Console Redirect functionality from the
> RACs integrated webserver works flawlessly, I can see and interact with the
> POST screen (enter setup etc), I can choose between kernels in the grub
> menu, and I can see all of the boot messages and login successfully on tty1
> once the system has finished booting.
> 
> However, I'm having not having as much luck with 2.6 kernels.. I've tried
> installing stock debian 2.6.8-686-smp and tried compiled my own 2.6.10, in
> both cases I can still interact with the POST screen, and can still select
> which kernel to boot from the grub menu, but as soon as the kernel begins to
> boot I loose the ability to provide keyboard input. I can still view the
> boot progress through to completion, but it seems my keystrokes are not
> being passed through as I'm unable to login once the system has booted.
> 
> The redirection is still actively working at this stage, as I can any kernel
> messages that get writted to tty1, and if I kill getty I can see it's output
> when it respawns, but I'm at a loss as to why I can no longer interact with
> the console remotely.
> 
> Has anyone else encountered this or have any suggestions as to what I should
> try next?
> 
> Kind Regards,
> Martin
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq




More information about the Linux-PowerEdge mailing list