Problem Serial console with Redhat Enterprise Version 3.

Diego_Leccardi@Dell.com Diego_Leccardi at Dell.com
Fri Mar 11 09:40:30 CST 2005


Hi ya,

I configured "Serial Port Redirection" as per the following article and
it always worked fine:

http://www1.us.dell.com/content/topics/global.aspx/power/en/ps1q03_stant
on?c=us&cs=555&l=en&s=biz 

I think that there are two errors in the configuration:

> serial console splashimage=(hd0,1)/grub/splash.xpm.gz

This should be commented out

>        kernel /vmlinuz-2.4.21-20.0.1.ELsmp ro root=LABEL=/
>        console=tty0 console=ttyS0,19200n8r

These two lines must be on the same line and not two separate lines.

Thanks

	Diego




-----Original Message-----
From: linux-poweredge-bounces-Lists On Behalf Of Daniel Schrock
Sent: 11 March 2005 15:27
To: jskim at ciscorp.c.kr
Cc: linux-poweredge-Lists
Subject: Re: Problem Serial console with Redhat Enterprise Version 3.

Just so you don't feel abandoned, since no one on the list has
responded.
We have the same issue that you are experiencing on the floowing
hardware:
3x PE6650
2x PE2650
4x PE1750

and last but not least, 1 Optiplex Workstation that i used to test
various options.

Kernel messages display just fine, then the display stops after init
until the login prompt appears.
no boot messages at all, yet if I use 'service' to stop/start/restart
while logged into the console, the messages display just fine.

You are not alone, but no one here seems to have any clue as to what is
going on.
I also tried a few RHEL/Dell IRC channels and got a little farther, but
no solution was ever found.

If you do figure it out, please pass the information along.

.daniel.schrock,ccnp
.senior.system/network.architect
.infrastructure.manager
.seko.worldwide.
.p.630.919.4876
==================
The Seko Infrastructure Team uses and recommends The Firefox Web Browser
http://www.mozilla.org/products/firefox/



jskim wrote:

>I am using PowerEdge 750 with Redhat Linux 3.0 update 3.
>And I am already setting up console login from serial. 
># grub.conf generated by anaconda
>#
># Note that you do not have to rerun grub after making changes to this 
>file # NOTICE:  You have a /boot partition.  This means that
>#          all kernel and initrd paths are relative to /boot/, eg.
>#          root (hd0,1)
>#          kernel /vmlinuz-version ro root=/dev/sda8
>#          initrd /initrd-version.img
>#boot=/dev/sda
>default=0
>fallback=1
>timeout=10
>serial --unit=0 --speed=19200 -word=8 --parity=no --stop=1 terminal 
>--timeout=10 serial console splashimage=(hd0,1)/grub/splash.xpm.gz
>title Red Hat Enterprise Linux ES (2.4.21-20.0.1.ELsmp)
>        root (hd0,1)
>        kernel /vmlinuz-2.4.21-20.0.1.ELsmp ro root=LABEL=/
>        console=tty0 console=ttyS0,19200n8r
>        initrd /initrd-2.4.21-20.0.1.ELsmp.img
>
># /etc/inittab
>:
>:
>c0:12345:respawn:/sbin/agetty 19200 ttyS0 vt100
>
># /etc/securetty
>:
>ttyS0
>
>
>But I can not see any boot log during booting and can not use keyboard 
>until Red Hat Linux completely booted from console.
>
>How Can I will be able to see boot log during the booting and using
keyboard to choose which kernel to boot ?
>
>Thanks
>
>
>
>==================================
>CISCOPR Copr.
>Name	: JeongSoo, Kim
>C/P	: 011-759-6408
>TEL	: 82-2-2168-8600 ext. 570
>Mail	: jskim at ciscorp.co.kr
>=============================
>
>_______________________________________________
>Linux-PowerEdge mailing list
>Linux-PowerEdge at dell.com
>http://lists.us.dell.com/mailman/listinfo/linux-poweredge
>Please read the FAQ at http://lists.us.dell.com/faq
>  
>

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq






More information about the Linux-PowerEdge mailing list