megaraid still being loaded when megaraid2 already in place

Anjan Dave adave at vantage.com
Wed Mar 9 13:11:01 CST 2005


I was able to do this on a RHES, latest update, PERC4/DC. Modified the
modules.conf and mkinitrd a new image, boot from it.

>From dmesg:
megaraid: v2.10.8.2-RH1 (Release Date: Mon Jul 26 12:15:51 EDT 2004)

Thanks,
Anjan


-----Original Message-----
From: Matt Domsch [mailto:Matt_Domsch at dell.com] 
Sent: Wednesday, March 09, 2005 9:23 AM
To: Ben
Cc: linux-poweredge at dell.com
Subject: Re: megaraid still being loaded when megaraid2 already in place

On Wed, Mar 09, 2005 at 02:04:22PM +0000, Ben wrote:
> I have a PowerEdge 1750 which I've managed to get to work from install
with 
> the megaraid2 driver by dint of editing the pcitable file in the 
> netstg2.img in a kickstart installation point such that all references
to 
> "megaraid" now read "megaraid2".  However, even though I have
> 
> alias scsi_hostadapter megaraid2
> 
> in my /etc/modules.conf (and nothing else scsi-related), the kickstart

> install loaded the megaraid2 driver and never mentioned megaraid, I'm
still 
> seeing this in dmesg on boot:

kudzu probably put it in modules.conf for you.
Just remake your initrd without 'megaraid' and reboot.

Thanks,
Matt

-- 

Matt Domsch
Software Architect
Dell Linux Solutions linux.dell.com & www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq




More information about the Linux-PowerEdge mailing list