CD still not recognized with kernel 2.6

Lawrence R. Mulder lmulder at informability.com
Wed Mar 2 10:08:01 CST 2005


Firstly, I would note that SATA and IDE are as different as IDE and SCSI
under linux since  SCSI is basically how linux treats SATA.  If your
kernel is recognizing the intel SATA controller, that is great, but I
wouldn't think that you have a SATA cdrom drive.

Secondly, Dell typicall uses a ServerWorks IDE chipset (I am not sure
about the PE 750) for IDE/ATAPI devices so that your cdrom would appear
as a standard ATAPI device, usually /dev/hda on their servers.

If you really have your cdrom connected to your SATA controller, linux
will see it as a SCSI device such as /dev/sda assuming your kernel is
loading the intel ACH SATA driver.

If you have ide-scsi emulation running, even a legacy IDE device may be
showing up as a SCSI cdrom device.

What does your /var/log/dmesg file say about storage devices from your
kernel's boot messages and are you sure all relevant controllers have
been enabled through your servers BIOS?

-Larry Mulder
Consultant/RHCE
www.informability.com

-----Original Message-----
From: linux-poweredge-admin at dell.com
[mailto:linux-poweredge-admin at dell.com] On Behalf Of Mi
Sent: Wednesday, March 02, 2005 9:17 AM
To: linux-poweredge at dell.com
Subject: CD still not recognized with kernel 2.6

I still haven't solved this problem, so I'm returning with the hope that

there is a solution.

The IDE CDROM drive is not recognized when using kernel 2.6 on a
Poweredge 
750 (with Debian Sarge).

lspci gives this for IDE:

0000:00:1f.2 IDE interface: Intel Corp. 6300ESB SATA Storage Controller 
(rev 02)

Does really nobody at Dell know how to get their CD recognized with a
2.6 
kernel?

Does anybody have it working?

The full Debian install report is available here:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=296762
or a shorter post here:
http://lists.us.dell.com/pipermail/linux-poweredge/2005-February/042752.
html

Some more info here (works with Knoppix on 2.4 kernel, not with
knoppix26):
http://lists.us.dell.com/pipermail/linux-poweredge/2005-February/042783.
html

Thank you,

M

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq






More information about the Linux-PowerEdge mailing list