Problems with a RAID array on a Dell PE1850

Ian P. Christian pookey at
Wed Dec 7 11:52:52 CST 2005

I'm having an odd problems with a poweredge 1850, and it's driving me mad - 
google's not helped me, and I've run out of places to look.

Basically, I can't use fdisk on /dev/sda.  I can however boot off this array, 
and everything is working fine - I'm having no issues using thie array for 
anything else.

# fdisk -l
Unable to seek on /dev/sda

# sfdisk /dev/sda --no-reread
Disk /dev/sda: 35669 cylinders, 255 heads, 63 sectors/track
llseek: Bad file descriptor

sfdisk: seek error on /dev/sda - cannot seek to 0
 /dev/sda: unrecognized partition table type
Old situation:
No partitions found

The odd thing is, if I boot off a gentoo liveCD, everything's ok.  

I've tried various kernel versions of the 2.6 series. 
I've tried using config's found on google.
I've tried configuing a kernel from scratch countless times.
I've tried repartitioning and reinstalling from scratch.
I've tried shouting at it.

extra info:
 # zcat /proc/config.gz  | grep MEG

 # lspci | grep RAID
02:0e.0 RAID bus controller: Dell PowerEdge Expandable RAID controller 4 (rev 

On a seperate note, anyone know how to upgrade firmware using Dell's software 
on a non-RH system?

# ./RAID_FRMW_LX_R107404.BIN
which: no lockfile in 
(/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3.6) Cannot find utilities on the system to execute package.
Make sure the following utilities are in the path: sed lockfile tail rm mkdir 
chmod ls basename

'lockfile' is missing - whatever that is!

Kind Regards,

Ian P. Christian ~
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the Linux-PowerEdge mailing list