PowerEdge 750 w/SATA RAID

Glenn Provoost glenn.provoost at dolphinsmind.be
Fri May 21 14:38:01 CDT 2004


Jeff,

--On vrijdag 21 mei 2004 13:51 -0400 Jeff Garzik <jgarzik at redhat.com> wrote:

> If you were using the drivers/scsi/ata_piix.c driver, then your
> devices would appear as /dev/sda not /dev/hdc.
>
> CONFIG_SCSI_SATA
> CONFIG_SCSI_SATA_PIIX
>
> Though Debian's 2.4.18 boot kernel is far too old to really support your
> hardware, without building a custom kernel.

I tried that initially and it worked very well from a performance point of 
view. I first installed my system on a spare IDE disk and when booting from 
that disk, everything worked fine. However, when I removed that disk and 
wanted to boot from the SATA disks (configured in a RAID-1 configuration), 
the drives weren't found by linux and consequently the root couldn't be 
mounted, resulting in a kernel panic.

I've only tried this together with a software RAID-1 configuration 
(root=/dev/md0) and not with stand-alone disks, but I'm pretty sure that my 
lilo config was correct.

Has anyone experienced anything similar?

Regards,

Glenn




More information about the Linux-PowerEdge mailing list