Dellomsa-drivers on Debian 2.4.26 kernel

Jim McLaughlin jim at stonewatercontrols.com
Thu May 20 20:47:00 CDT 2004


On Thu, 2004-05-20 at 15:56, Elwyn Malethan wrote:
> Hi All,
> 
> I've seen discussions about dellomsa-drivers and other kernel versions. 
> They were very helpful but I'm still in a fix. I am running kernel 
> version 2.4.26 (see below uname output) with debian (woody) on a 
> PowerEdge 6450.
> 

I did this awhile ago and I've missed two releases. The version I used
was 4.71, which still works fine. I'm not sure what features 4.9 and
4.12 added, but they obviously depend on rh specific exports in the
kernel. I opened up the 4.9 and 4.12 debs, and esm.o is built by
compiling one source file and linking 34 object files included in the
package. So it is not entirely true when it says it is building the
drivers against the running kernel. I suspect the guy who built those
debs was running a redhat kernel on debian. Until dell understands the
benefits of opening the driver source, we can either do the same or run
4.71, which is what I am doing now.


-- 
/**
 * Jim McLaughlin
 * Senior Software Engineer
 * Stonewater Control Systems
 */




More information about the Linux-PowerEdge mailing list