Dellomsa-drivers on Debian 2.4.26 kernel

Elwyn Malethan linux-poweredge at goatnet.co.uk
Thu May 20 15:57:01 CDT 2004


Hi All,

I've seen discussions about dellomsa-drivers and other kernel versions. 
They were very helpful but I'm still in a fix. I am running kernel 
version 2.4.26 (see below uname output) with debian (woody) on a 
PowerEdge 6450.

Jim McLaughlin <jim at stonewatercontrols.com> 08/12/03 04:20PM
> Did you make .debs for the kernel using make-kpkg and then install with 
> dpkg -i. If not, then dpkg will think you're running a different kernel 
> and the dependency checks will fail. make-kpkg comes in the 
> kernel-package package.

I didn't use make-kpkg but I've manually compiled all my kernels in the 
past so I think I've performed all the tasks I need to so that the 
system knows which kernel it's using.

Have I missed a crucial step (I don't think I have) or do the drivers 
only support kernel version 2.4.20? Is the fact that I'm using version 
2.4.26 causing the error below or is there something else. Is there 
another (newer) version of the drivers perhaps?

Below is also an extract from my history as far the recompiling and 
installation of the kernel is concerned. Any help or pointers would be 
very gratefully received.

Cheers :)

Elwyn

------------------------------------------------------------------
HISTORY EXTRACT
---------------
make xconfig
make dep
make bzImage
make modules
make modules_install
cp arch/i386/boot/bzImage /boot/vmlinuz-2.4.26
cp System.map /boot/System.map-2.4.26
cd /
ln -sf /boot/vmlinuz-2.4.26 vmlinuz
ln -sf /boot/vmlinuz-2.4.18-bf2.4 vmlinuz.old
lilo -v
shutdown -r now

------------------------------------------------------------------
ATTEMPT TO INSTALL DRIVERS
--------------------------
exodus:~# dpkg -i dellomsa-drivers_4.90-3825_i386.deb
(Reading database ... 20113 files and directories currently installed.)
Preparing to replace dellomsa-drivers 4.90-3825 (using 
dellomsa-drivers_4.90-3825_i386.deb) ...
  Removing any system startup links for /etc/init.d/dellomsaesm ...
cp: cannot stat `/lib/modules/2.4.26/misc/esm.o': No such file or directory
Unpacking replacement dellomsa-drivers ...

dellomsa-drivers-4.90-3824.i386.rpm: Uninstall was SUCCESSFUL!

Setting up dellomsa-drivers (4.90-3825) ...

Building device driver for running kernel:                 [OK]

Loading Server Administrator Device Drivers:               [FAILED]

Running kernel is not supported.
See Dynamic Kernel Support in the Server Administrator readme.txt file.

Run rpm using the -e option to clean up the RPM database. Enter:
rpm -e dellomsa-drivers-4.90-3824

dellomsa-drivers-4.90-3824.i386.rpm: Upgrade was NOT successful! ERROR 44

dpkg: error processing dellomsa-drivers (--install):
  subprocess post-installation script returned error exit status 44
Errors were encountered while processing:
  dellomsa-drivers

------------------------------------------------------------------
UNAME OUTPUT
------------
exodus:~# uname -a
Linux exodus 2.4.26 #1 SMP Mon May 10 23:43:17 BST 2004 i686 unknown

------------------------------------------------------------------

--
Elwyn Malethan




More information about the Linux-PowerEdge mailing list