Grub / Boot Problem

nathan r. hruby nhruby at uga.edu
Tue May 18 11:56:01 CDT 2004


On Tue, 18 May 2004 nospam at wayob.org wrote:

> > Grant.
> >
> > Try booting with the Linux cd to rescue mode, login as root and run grub.
> > Once you have the grub prompt, type "find /boot/grub/stage1" or "find
> > /grub/stage1" depending on the pathing, without the quotes. The command
> > should return something to the effect of (hd0,0).  At the prompt, type
> > "root
> > (hd0,0)" or whatever was returned in the previous command, and hit enter.
> > Again at the prompt type "setup (hd0)".  That should reinstall the grub
> > boot
> > loader. Quit out of grub, exit out of rescue mode and reboot.  You should
> > be
> > good to go. HTH
> >
> > Regards, Marshall
> 
> Thanks Marshall, for the note.  I tried these instructions to the tee, but
> no luck.  No errors, the root was (hd0,0) and the all the commands worked
> as expected, but the system still would not boot.
> 
> I installed LILO as Jason recommended and that worked OK.
> 

Note that if you have Serial Console Redirection turned on in BIOS along
with the option to keep displaying after the OS boots *and* grub is
configured to have a serial condole this will happen.  The solution (that
I found) was to simple change the Redirection Option to just display the
POST, as grub will pick up perfectly as it knows about serial devices
(lilo doesn't)

HTH,

-n
-- 
-------------------------------------------
nathan hruby <nhruby at uga.edu>
uga enterprise information technology services
production systems support
metaphysically wrinkle-free
-------------------------------------------




More information about the Linux-PowerEdge mailing list