Missing megaraid_2002 from e.40

George Bagley poweredge at redeye.com
Mon May 3 11:10:00 CDT 2004


Hi all

I believe the latest driver for the perc controllers is the megaraid2
driver.

The driver version which is built into kernel 2.4.9e40 is v2.10.1.1.

Here is the bit of our build doc which involves changing the kernel to use
the megaraid2 driver.

28.  Change the default megaraid driver for the RAID controllers

		vi /etc/modules.conf

Change "alias scsi_hostadapter megaraid"      to "alias scsi_hostadapter
megaraid2".  
Change "alias scsi_hostadapter megaraid_2002" to "alias scsi_hostadapter
megaraid2".

You will then need to do a mkinitrd. 

For the SMP kernel
		cd /boot
		mv initrd-2.4.9-e.40smp.img initrd-2.4.9-e.40smp.img.saved
		mkinitrd -v -f /boot/initrd-2.4.9-e.40smp.img 2.4.9-e.40smp

For the enterprise kernel  ( >= 4GB machines or >= 4 processors)
		cd /boot
		mv initrd-2.4.9-e.40enterprise.img
initrd-2.4.9-e.40enterprise.img.saved
		mkinitrd -v -f /boot/initrd-2.4.9-e.40enterprise.img
2.4.9-e.40enterprise 

To check the running version of the module after a reboot use the following
commands.

		dmesg | grep "megaraid"

To get more details about the modules, use the following commands

		lsmod | grep raid
		modinfo -n megaraid2

I have not heard about (or tried) the 2009 driver - however to my knowledge
the 2.10.1.1 driver is the latest and most stable driver.  I am guessing
that the 2009 driver is actually 2.00.9?

George



-----Original Message-----
From: linux-poweredge-admin at dell.com [mailto:linux-poweredge-admin at dell.com]
On Behalf Of Michael Graham
Sent: 03 May 2004 10:28
To: linux-poweredge at dell.com
Subject: Re: Missing megaraid_2002 from e.40



> Have just run the up2date for new kernels on Redhat ES 2.1
> to install the new kernel version 2.4.9-e.40 and it seems
> to be missing the megaraid_2002 module. As you can see in
> the grub.conf the initrd lines are missing.

I encountered this problem too.  So many megaraid drivers, so many
versions...
Anyway, it turns out the megaraid_2009 driver is the current one and
supercedes
megaraid_2002.  At least, this worked for us on our PE 1750 with a Perc/4Di
controller.

Here's what I did:

  1. changed /etc/modules.conf to point to megaraid_2009 instead of
     megaraid_2002 (this is necessary for step 2)

  2. run mkinitrd:

      $ cd /boot
      $ sudo /sbin/mkinitrd initrd-2.4.9-e.40.img 2.4.9-e.40 -f -v

  3. edit /boot/grub/menu.lst to point to the new initrd, e.g:

         title Red Hat Linux (2.4.9-e.40)
            kernel /vmlinuz-2.4.9-e.40 ro root=/dev/sda7
            initrd /initrd-2.4.9-e.40.img



Michael


--
Michael Graham
magog at the-wire.com

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list
archives at http://lists.us.dell.com/htdig/







More information about the Linux-PowerEdge mailing list