Linux Win, slow no matter what. Help would be appreciated....

Seth Mos knuffie at xs4all.nl
Sat Mar 1 07:39:01 CST 2003


On Fri, 28 Feb 2003, Robert Lindgren wrote:

> On Sat, 1 Mar 2003 07:37:48 +1000 (EST)
> jason andrade <jason at rtfmconsult.com> wrote:
>
> > On Fri, 28 Feb 2003, Robert Lindgren wrote:
> >
> > > The server I run the tests on was a 2650, dual 2.4, 6gb ram, 3 fujitso map3735nc 73GB drives, and the perc3/Di/adaptec 7889/adaptec 29160 cards.
> >
> > as seth has suggested, turn off the 6G and perhaps configure the additional 2G as
> > "sparebank"
>
> I did actually run most of the tests with just 1GB of ram to be able to save some time.

Ah, but booting with mem=1024 instead of recompiling the kernel without
PAE support will still result in skewed results. File servers and PAE
don't seem to mix that well. Use PAE and the full 6GB when you are running
databases and you need the extra memory.

> >  also, make sure you are running on the latest version of the
raid firmware.
>
> Yes it's the latest version, just got this server a couple of days ago.

Ahem, getting your server a few days ago does not mean it actually has the
latest firmware. Better check this if you did not already do so. It should
be something like 2.7.1 for adaptec based raid controllers.

> As I said the where not that much difference regardless what config I ran, when it comes to write performance. Regarding read ext3 (data=journal) was the slowest, reiserfs little faster and ext3 (data=writeback) fastest. Can post some figures later when I've got more time if it is of any interest.

Have you tried using XFS for the data partition? I use XFS on production
machines for over a year without significant problems.

The performance should be alright. A few days ago a post to the list was
made with the performance differences for XFS vs ext3 in a renderfarm
where it was used as the NFS fileserver. You can check the archives.

If you want to try it, you can find the new XFS 1.2 release from the
website http://oss.sgi.com/projects/xfs/ and if you need errata kernels
with the XFS 1.2 patch you can find those on my site
http://iserv.nl/files/xfs/

Don't forget fetching the userspace tools from the oss website.

> Yes the system is unresponsive with hw raid, when in I/O bottleneck has kicked in. Can run any program like ps,w (or anything else for that matter), sure I'm to run it after a couple of sec (5-15sec), same in windows pressed the start menu, took 10-15 sec for it to pop up.

My sixth sense says that it has to do with the Highmem support. Have you
tried actually taking the extra ram and sticking to 4GB?

Cheers
Seth




More information about the Linux-PowerEdge mailing list