PowerVault 100T TR40 Travan

Brian Smith BSmith at lyrix.com
Tue Jan 28 10:25:01 CST 2003


Ben,

Based on the list of problems you report, my guess is the IDE BUS itself.
Try a new cable.  If it's got a 40pin IDE cable, install an 80pin cable.
Don't fold the cable too hard.  Try removing the CDROM from the cable.
Verify the IDE settings in the BIOS - dma mode, etc.  Try the tape drive in
another system if possible to see if the same problems are experienced
there.

- Brian



                                                                                                                          
                    bscott at ntisys.com                                                                                     
                    Sent by:                    To:     linux-poweredge at dell.com                                          
                    linux-poweredge-admi        cc:                                                                       
                    n at dell.com                  Subject:     PowerVault 100T TR40 Travan                                  
                                                                                                                          
                                                                                                                          
                    01/28/03 10:23 AM                                                                                     
                                                                                                                          
                                                                                                                          





  We have a customer who has a Dell PowerEdge 600SC with a PowerVault 100T
TR40.  Has anyone ever gotten one of these things to work reliably with
Linux?  We've had no end of trouble.  We've even had Dell field service
replace the drive, but it still doesn't work right.  I'm no fan of Travan
to
begin with, but I wasn't involved in the purchasing decision on this one,
and this seems pretty bad even for Travan.


  Problems:

  - tar will write some amount of data (less then 500 MB) and then fail
    with a short write error.
  - tar or mt will randomly fail with "I/O error" messages
  - tar or mt will randomly hang in the D (uninterruptible sleep) state.
    Ejecting the tape will sometimes cause them to unwedge and abort;
    other times the system will need to be rebooted.
  - The drive will wedge and refuse to do anything (even eject the tape)
    until power cycled.
  - Tons of errors in the kernel log about the device whenever it is in
use.

  Some of the kernel errors we see are:

- Error with sense data: Current st09:00: sense key Illegal Request
  Additional sense indicates Invalid command operation code

- st0: Error with sense data: Info fld=0x0, Current st09:00: sense key
Illegal Request
  Additional sense indicates Invalid command operation code

- aborting command due to timeout : pid 89209, scsi1, channel 0, id 0, lun
0 Rezero Unit 00 00 00Jan 24 14:43:52
  hdb: irq timeout: status=0xd0 { Busy }
  hdb: ATAPI reset timed-out, status=0xd0
  ide0: reset: success
  st0: Error with sense data: Current st09:00: sense key Unit Attention
  Additional sense indicates Power on,reset,or bus device reset occurred


 We have tried several different tapes, all brand new, so we are fairly
sure
the problem is not bad media.  We have also tried re-tensioning the tapes.


  I downloaded the latest Seagate tape diagnostics from

           http://www.seagate.com/support/tape/utils/stdiag.html

Whenever I try to invoke the "diagsvlx" utility, however, it just dies with
a Segmentation Fault.  Running "strace" shows that it is dying very early
on, during dynamic library initialization from the look of it.


  We are using the device in IDE/SCSI emulation mode.  The "ide-scsi" and
"st" modules are loaded.  The "ide-tape" module is *NOT* loaded.


  I have tried all three of the suggested commands in the Dell User Guide.

Results are as follows:

# insmod ide-scsi
Using /lib/modules/2.4.18-10/kernel/drivers/scsi/ide-scsi.o
# hdparm -d0 /dev/hdb

/dev/hdb:
 setting using_dma to 0 (off)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)
# mt -f /dev/st0 stoptions no-blklimits
#


  The system is a PowerEdge 600SC.  The OS is Red Hat Linux 7.3 (kernel
2.4.18-10).  The drive is a PowerVault 100T TR40 (20 GB IDE Travan).  It
appears to be a re-badged Seagate TapeStor Travan 40 (STT3401A).  It is
connected to the primary IDE channel on the motherboard, along with the IDE
CD-ROM.  The hard disks in the system are attached to an IDE RAID
controller
(CERC ATA/100).


  Anyone have any ideas?


--
Ben Scott           | Net Technologies, Inc.  | 978-462-8795
Network Engineer    | Salisbury, MA, USA      | 866-NTI-LINUX (684-5468)
bscott at ntilinux.com | http://www.ntilinux.com | Fax: 978-499-7839

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list
archives at http://lists.us.dell.com/htdig/







More information about the Linux-PowerEdge mailing list