Server Adminsitrator for new kernel 2.4.18-18.7.x

Lee, David Y. dlee at SLAC.Stanford.EDU
Fri Jan 24 14:01:00 CST 2003


Yes, I didn't have the appropriate kernel source installed (doh). After installing the kernel source, the drivers load, however the start_test.sh script fails:

[root at web01 APP_322_LNX]# ./start_text.sh 
Turning off DMA on IDE CDROM drives.
Disabling DMA for CDROM /dev/hda
Message: [Start] -> Please wait
./sysid: error while loading shared libraries: libdchapi32.so.4: cannot open shared object file: No such file or directory
Exception in thread "main" java.lang.UnsatisfiedLinkError: /tmp/APP_322_LNX/linux/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1382)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1298)
        at java.lang.Runtime.loadLibrary0(Runtime.java:749)
        at java.lang.System.loadLibrary(System.java:820)
        at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:53)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoader.java:41)
        at sun.awt.DebugHelper.<clinit>(DebugHelper.java:29)
        at java.awt.Component.<clinit>(Component.java:356)
        at setupClass.<init>(setupClass.java:616)
        at setupClass.main(setupClass.java:271)

-----Original Message-----
From: Michael Redinger [mailto:Michael.Redinger at uibk.ac.at] 
Sent: Friday, January 24, 2003 11:31 AM
To: linux-poweredge at dell.com
Subject: RE: Server Adminsitrator for new kernel 2.4.18-18.7.x



Any chance that the version of your kernel sources differs from the kernel 
you use?

Michael


--
Michael Redinger
Zentraler Informatikdienst (Computer Centre)
Universitaet Innsbruck
Technikerstrasse 13                     Tel.: ++43 512 507 2335
6020 Innsbruck                          Fax.: ++43 512 507 2944
Austria                                 Mail: Michael.Redinger at uibk.ac.at


On Fri, 24 Jan 2003, Lee, David Y. wrote:

> I tried following Jason's instructions on his site as well as bits 
> I've found on the mailing list archive, yet still no go:
> 
> RH7.2, 2.4.18-18.7.x, PE1550
> 
> After installing the dellomsa-drivers rpm, then modifying dcesm.c, and 
> executing './dellosmaesm start', I get:
> 
> [root at web01 bin]# ./dellomsaesm start
> Building device driver for running kernel:                 [  OK  ]
> Loading Server Administrator Device Drivers:               [FAILED]
> See /var/tmp/esm.map for output from insmod.
> See Dynamic Kernel Support in the Server Administrator readme.txt 
> file.
> 
> [root at web01 tmp]# cat esm.map
> /lib/modules/2.4.18-18.7.x/misc/esm.o: kernel-module version mismatch
>         /lib/modules/2.4.18-18.7.x/misc/esm.o was compiled for kernel version 2.4.18-17.7.x
>         while this kernel is version 2.4.18-18.7.x.
> 
> I was under the assumptiong that the dynamic kernel support would 
> build the driver for this kernel as well?
> 
> I'm sure I've done something stupid, any help?
> 
> Thanks
> Dave
> 
> 
> -----Original Message-----
> From: Brian J. Smith-Sweeney [mailto:bsweeney at physics.ucsb.edu]
> Sent: Tuesday, December 10, 2002 2:49 PM
> To: jason andrade
> Cc: linux-poweredge at dell.com
> Subject: Re: Server Adminsitrator for new kernel 2.4.18-18.7.x
> 
> 
> On Tue, 2002-12-10 at 14:14, jason andrade wrote:
> > On 10 Dec 2002, Brian J. Smith-Sweeney wrote:
> > 
> > > FYI, those instructions didn't completely work for me.  When I got
> > > to the point where I'd run the start_text.sh script it would 
> > > overwrite my edited module and fail to run . Other folks expressed 
> > > similar issues on the dell forums; see the following thread for more 
> > > info:
> > 
> > Sorry Brian.  I've generally just used the install script as i've
> > usually done a RH7.3 fresh install, kernel update to 2.4.18-10, OMSA 
> > 1.2 install, kernel update to 18-18.7.x, OMSA 1.2 patch, which has 
> > worked ok.
> > 
> > I've been given some additional information by Steve and inserted 
> > that
> > into the text message that was archived there (basically the minor 
> > change is to install the dellomsa as well as dellomsa-drivers)
> > 
> > I've taken the forum bits out and added them to the text file for
> > future reference.
> > 
> No worries; I'm glad the install instructions are there!  They kept me 
> from doing my headers hack that I was worried about (earlier post).  I 
> just mentioned it b/c I know lots of people on this list have pointed 
> to those instructions, and the additions from the forum are pretty 
> key.
> 
> -Brian
> 


_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list archives at http://lists.us.dell.com/htdig/




More information about the Linux-PowerEdge mailing list