SMP Linux will not boot - PE6650

Rechenberg, Andrew ARechenberg at shermanfinancialgroup.com
Fri Jan 24 07:42:01 CST 2003


That thread was in response to a question that I posed.  I still have
not tried to compile and boot a 2.4.20 vanilla kernel with the
modification.  I would like to try because we have been having some
awful problems with I/O performance (the megaraid module leaves
something to desire :), but I haven't had the down time with the box
because it is in production almost 24/7

If I get the down time, I'll try 2.4.20 and post the results to the
list.  Has anyone successfully booted a 66x0 with a vanilla 2.4.20
kernel?

Thanks,
Andy.

-----Original Message-----
From: Desai, Jason [mailto:jase at sensis.com] 
Sent: Thursday, January 23, 2003 5:50 PM
To: 'linux-poweredge at dell.com'
Subject: SMP Linux will not boot - PE6650


Hello.  I just got my shinny new Dell Power Edge 6650 with 4 Xeon
processors
and 8 Gb of ram.  I have installed Debian Linux on it with no problem.
However, when I try to install an SMP kernel, it will not boot.  I get
an
error about a Kernel bug at smpboot.c and then a dump of some registers.
The a kernel message - something like 

Attempted to kill the idle task
In idle task - not syncing

I have tried this with kernels 2.4.19 and 2.4.20.

I have searched the archives and found here
(http://lists.us.dell.com/pipermail/linux-poweredge/2002-October/010091.
html
) that someone suggested increasing MAX_MP_BUSSES to 64.  I compiled my
own
2.4.20 kernel with that change, but I'm still having the same problem.

Has anyone else run across this?  Non SMP kernels seem to run just fine.

Thanks for any help!

Jason Desai

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq or search the list
archives at http://lists.us.dell.com/htdig/




More information about the Linux-PowerEdge mailing list