Slackware 8.1, PowerEdge 1650 and PERC3/Di

Paul paul at kbs.net.au
Tue Jan 14 18:35:01 CST 2003


Amadej,

I have several PowerEdge 2550's and 2500's running Perc 3/Di's on Slackware 8.0 and Slackware 8.1
I built a bootdisk for Slackware 8 which is on the domsch.com/linux website that works for a 2500/2550 and should for a 1650 also.
Let me know how you go with the disk you are trying tomorrow and I'll see what I can help you out with.
Slackware 8.0 is easier to install with the AACRAID drivers as 8.1 is 5 boot disks (install.1, install.2, install3 etc...) instead of 2 (normal bare.s and color.gz)
Try using raid.s as the boot disk image and it should work. Let me know how you go...

Regards,

Paul Rivoli
paul at kbs.net.au
K B S   I N T E R N E T

  ----- Original Message ----- 
  From: Amadej Bukorovic 
  To: linux-poweredge at dell.com 
  Sent: Wednesday, January 15, 2003 9:54 AM
  Subject: Slackware 8.1, PowerEdge 1650 and PERC3/Di


  Hello everyone,

  I just recived two Dell PowerEdge 1650 servers at the office today and wanted to install Slackware Linux version 8.1 on them

  but I seem to have a bit of a problem with getting the kernel to work with the PERC3/Di RAID card, which presents a problem since I want to install Slackware on the RAID partition.



  I’ve been going at it for a whole day with little luck. As you all probably know, Slackware 8.1 doesn`t include an install

  kernel/boot disk with aacraid driver. I`m assuming that is the appropriate driver for the RAID card, judging from the information

  I got at http://domsch.com/linux/#aacraid .



  I’ve searched trugh the net and all I found was a premade bootdisk for SlackWare 8.0 (one with aacraid driver built in

  and one with aacraid driver and raiserfs support built in) and a bootdisk for SlackWare 8.1 with built in megaraid driver,

  which isn’t the right driver from what I understand (I’ve also tried it and it didn’t work… just to be sure)– all of the boot disks were found on domsch.com.



  Just for the sake of it I tried these slackware 8.0 boot disks but I didn`t see the kernel detect the RAID, all I got after the driver loaded was an error saying:

  kmod: failed to exec /sbin/modprobe –s –k scsi_hostadapter,errno = 2



  I made a custom kernel (with built in aacraid drivers) and a bootdisk with bare.i, then copyed over bzImage and System.map.gz (don’t ask me why I chose this weird way of creating a custom boot disk ☺ ). I didn't try it out yet, I'll do that tommorow, but I have a bad feeling of it not working (since the other 8.0 bootdisks didn't work either).



  So now here's my question... has anyone installed SlackWare 8.0 or even better yet version 8.1 on a PERC3/Di (or something simular that is supported by aacraid) before and if yes, how did you get it to work?



  Does anyone have any good ideas as to what I should try next becaouse I'm kind of running out of ideas and there seems to be little info on support for this RAID controler apart from working (or so I hear) drivers for RedHat?



  Any ideas or info would be apreshiated, and thanks to all in advance!



  Amadej.



  BTW: Please excuse my bad spelling J




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20030114/3b07c545/attachment.htm


More information about the Linux-PowerEdge mailing list