Slackware 8.1, PowerEdge 1650 and PERC3/Di

Amadej Bukorovic amadej at
Tue Jan 14 16:55:01 CST 2003

Hello everyone,

I just recived two Dell PowerEdge 1650 servers at the office today and wanted to install Slackware Linux version 8.1 on them

but I seem to have a bit of a problem with getting the kernel to work with the PERC3/Di RAID card, which presents a problem since I want to install Slackware on the RAID partition.


I’ve been going at it for a whole day with little luck. As you all probably know, Slackware 8.1 doesn`t include an install

kernel/boot disk with aacraid driver. I`m assuming that is the appropriate driver for the RAID card, judging from the information

I got at .


I’ve searched trugh the net and all I found was a premade bootdisk for SlackWare 8.0 (one with aacraid driver built in

and one with aacraid driver and raiserfs support built in) and a bootdisk for SlackWare 8.1 with built in megaraid driver,

which isn’t the right driver from what I understand (I’ve also tried it and it didn’t work… just to be sure)– all of the boot disks were found on


Just for the sake of it I tried these slackware 8.0 boot disks but I didn`t see the kernel detect the RAID, all I got after the driver loaded was an error saying:

kmod: failed to exec /sbin/modprobe –s –k scsi_hostadapter,errno = 2


I made a custom kernel (with built in aacraid drivers) and a bootdisk with bare.i, then copyed over bzImage and (don’t ask me why I chose this weird way of creating a custom boot disk ☺ ). I didn't try it out yet, I'll do that tommorow, but I have a bad feeling of it not working (since the other 8.0 bootdisks didn't work either).


So now here's my question... has anyone installed SlackWare 8.0 or even better yet version 8.1 on a PERC3/Di (or something simular that is supported by aacraid) before and if yes, how did you get it to work?


Does anyone have any good ideas as to what I should try next becaouse I'm kind of running out of ideas and there seems to be little info on support for this RAID controler apart from working (or so I hear) drivers for RedHat?


Any ideas or info would be apreshiated, and thanks to all in advance!




BTW: Please excuse my bad spelling :-)



-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Linux-PowerEdge mailing list