"tg3_stop_block timed out" problem

Brian J. Smith-Sweeney bsweeney at physics.ucsb.edu
Mon Jan 13 16:30:00 CST 2003

Hello all-

We just moved a Dell PE2650 into our server room, and when we booted it
up connected to the new switch it took a long time to get past the
network startup.  This is a RHL 7.3 box with the latest 2.4.18-19.7.x
kernel using the tg3 drivers since as far as I know they're working
now.  When the machine finally booted, it was not on the network.  Link
light was up, but couldn't ping.  tcpdumping showed NO traffic. 
strange.  So I switched the cable to the other NIC port, brought up that
interface, and tcpdumped which showed normal traffic.  Brought cable
back over to the original port, still nothing.  Tried to bring down the
interfaces using ifdown, and it took a second after which it said:

	 tg3: tg3_stop_block timed out, ofs=2400 enable_bit=2

I reloaded the tg3 module, and then everything worked ok.  Rebooting
brought the machine right back up, no errors this time.

The only place I could find this error was on the driver development
list from August, before the latest tg3 driver was out.  

Has anyone else seen this error on their PE?  I'm a bit nervous as we
were moving this system into the server room with the intention of
migrating our production email service onto it this friday.  Everything
until now has been fine since I put in the new kernel.

Thanks in advance,
Brian Smith-Sweeey
Senior Systems Administrator
University of California, Santa Barbara
Physics Department
bsweeney at physics.ucsb.edu

More information about the Linux-PowerEdge mailing list