keyboard dies at login screen

Michael Redinger Michael.Redinger at uibk.ac.at
Sat Jan 11 12:53:00 CST 2003


Hi,

I had this problem twice (quite some time ago, I think this was PE 1300).
It was exactly the same stroy - identical machines, identical setups, but 
keyboard probs on one of the machines.

I called Dell Support, they changed the mainboard. Things worked fine 
afterwards ...

I don't really know what exactly the problem was. I wasn't really 
interrested, I was happy enough that it worked ... :)


Michael

On Sat, 11 Jan 2003, Brian Jones wrote:

> Hi,
> 
> This is kinda kooky.  Wondering if anyone's seen this issue.
> 
> I have 3 PE2650's, all configured exactly the same from both a hardware 
> and software standpoint.  They're all running from the same Redhat 7.3 
> kickstart template, and when I configured the kernels, I did one, saved 
> the config to a file, and used the file for the other kernels.  They're 
> all running 2.4.20, by the way.
> 
> So two of the boxes come up spectacularly.  Yay me.  The third one 
> *looks* like everything is going fine... the lights on the keyboard 
> flash, and the keyboard is usable at the Grub boot screen (ie, I can 
> select which kernel I wanna boot, etc).  It's also usable during the 
> service startup (ie, during eth0 initialization, which always takes a 
> few seconds, I can hit enter and stuff and see results).  However, as 
> soon as the login prompt is displayed, the keyboard becomes unusable!
> 
> So I figured I'd run delldiag on the sucker, but the problem is, while 
> I can get around in the early stages of loading modules in delldiag and 
> all (ie, I can hit 'ok' when I load a new floppy), once I get to the 
> menu where I'm supposed to tell delldiag what to do, I can't use the 
> keyboard again!!  ACK!
> 
> I've tried all the usual troubleshooting stuff; using known good 
> keyboards, plugging in the keyboard directly instead of going via the 
> KVM switch, etc.  Trying a couple of different brand keyboards (one was 
> a Dell) :-), making sure everything was connected properly, using both 
> 'Off' and 'On' settings in the BIOS for 'numlock', etc.  I can't think 
> of what else I can do.  Redhat's logs contain nothing about the 
> keyboard, and dmesg and everything else looks normal AFAIK.
> 
> Any clues here?
> brian.
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq or search the list archives at http://lists.us.dell.com/htdig/
> 
> 

-- 
Michael Redinger
Zentraler Informatikdienst (Computer Centre)
Universitaet Innsbruck                  
Technikerstrasse 13                     Tel.: ++43 512 507 2335
6020 Innsbruck                          Fax.: ++43 512 507 2944
Austria					Mail: Michael.Redinger at uibk.ac.at




More information about the Linux-PowerEdge mailing list