Perc4/Di Driver Disk for SuSe Enterprise Server 8.0

Andrew McCall it.andrew.mccall at oldham.gov.uk
Tue Jan 7 10:40:09 CST 2003


Paul wrote:
> Hi All,
> 
> I have done some more work with the megaraid driver disk for SLES 8.0 and
> ran into some problems.
> I have rebuilt a driver disk based off 2.4.19 on a clean SLES8.0 IDE box and
> included megaraid-1.18f.
> This seemed to work fine. Packaged it all up in the appropriate paths and
> made the driver disk.
> SLES 8.0 still doesnt seem to find the controller/drives after loading the
> additional modules from the driver disk.
> 
> I tried going into rescue mode and booted to a kernel prompt. I then mounted
> the floppy and did an insmod on the megaraid.o
> This worked correctly and it located both of the channels on the controller.
> I did not however list any containers or drives on the controllers.
> I'm not sure if this is due to it being a rescue disk and it has already
> done the scsi channel probing despite no controllers being found or I'm
> doing something wrong. I've tried to locate some form of scsi probing apps
> on the rescue disk but none were found.
> 
> Does anyone have any more tips or advice? I've got a sucessful 1.18f built
> module just dont have the matching driver disk.
> I can send the megaraid.o binary if someone could even package it for me or
> suggest another way to do it
> 
> My disk looks like...
> 
> /linux/suse/i386-8.0/modules/megaraid.o
> 
> I've also made the following mirrored trees in case the arch is different,
> but when in rescue mode its listed as i686 via uname
> 
> /linux/suse/i386-8.0/modules/megaraid.o
> 
> /linux/suse/i586-8.0/modules/megaraid.o
> 
> /linux/suse/i686-8.0/modules/megaraid.o
> 
> 
> So all in all we have those above and the other usual pre-scripts and stuff,
> which I have done anything with.
> Still doesn't seem to work correctly. Do I need to update any other files or
> images on the driver disk?
> I haven't modified the initrd scripts or update.pre scripts as I'm not sure
> what to modify, let alone why...
> 
> Thanks for all your help and time.
>

Try

/lib/modules/<kernel-version>/modules/megaraid.o

To find the exact kernel version that your system uses at boot up, press 
CTRL-ALT-F2 and type uname -a, under SuSE Linux Professional 8.0 its 
2.4.18-4GB.

I have made a driver disk with 1.18a on it, and done this - but it still 
doesn't work :(

Any help for me would be great too :)
-- 
Thanks,

Andrew McCall
Internet/Linux System Administrator
I.C.T. Division
Oldham MBC
Civic Centre
West Street
Oldham
OL1 1UU

Tel : 0161 911 3990
Fax : 0161 911 3998
Email : it.andrew.mccall at oldham.gov.uk



**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.oldham.gov.uk
**********************************************************************




More information about the Linux-PowerEdge mailing list