Perc4/Di Driver Disk for SuSe Enterprise Server 8.0

Chambraud, Guillaume guillaume.chambraud at eds.com
Tue Jan 7 05:15:00 CST 2003


Hi Paul,
Because I've just subscribe, I didn't receive this mail ... but your
experience really interest me because we've got the same problem.
Could you directly send me your "1.18f megaraid module disk" image, I'll try
to use it myself and allow us to succeed in our installation.

PS : Paul Rivoli , are you french ? If so, do not hesitate to speak french
when replying to me ;-)

Thanks

> Hi All,
> 
> I have done some more work with the megaraid driver disk for SLES 8.0 and
> ran into some problems.
> I have rebuilt a driver disk based off 2.4.19 on a clean SLES8.0 IDE box
and
> included megaraid-1.18f.
> This seemed to work fine. Packaged it all up in the appropriate paths and
> made the driver disk.
> SLES 8.0 still doesnt seem to find the controller/drives after loading the
> additional modules from the driver disk.
> 
> I tried going into rescue mode and booted to a kernel prompt. I then
mounted
> the floppy and did an insmod on the megaraid.o
> This worked correctly and it located both of the channels on the
controller.
> I did not however list any containers or drives on the controllers.
> I'm not sure if this is due to it being a rescue disk and it has already
> done the scsi channel probing despite no controllers being found or I'm
> doing something wrong. I've tried to locate some form of scsi probing apps
> on the rescue disk but none were found.
> 
> Does anyone have any more tips or advice? I've got a sucessful 1.18f built
> module just dont have the matching driver disk.
> I can send the megaraid.o binary if someone could even package it for me
or
> suggest another way to do it
> 
> My disk looks like...
> 
> /linux/suse/i386-8.0/modules/megaraid.o
> 
> I've also made the following mirrored trees in case the arch is different,
> but when in rescue mode its listed as i686 via uname
> 
> /linux/suse/i386-8.0/modules/megaraid.o
> 
> /linux/suse/i586-8.0/modules/megaraid.o
> 
> /linux/suse/i686-8.0/modules/megaraid.o
> 
> 
> So all in all we have those above and the other usual pre-scripts and
stuff,
> which I have done anything with.
> Still doesn't seem to work correctly. Do I need to update any other files
or
> images on the driver disk?
> I haven't modified the initrd scripts or update.pre scripts as I'm not
sure
> what to modify, let alone why...
> 
> Thanks for all your help and time.
> 
> Regards,
> 
> Paul Rivoli
> paul at kbs.net.au
> K B S   I N T E R N E T




More information about the Linux-PowerEdge mailing list