Dell PE2550 and RedHat Linux 7.1 & kernel upgrade

Matt_Domsch@Dell.com Matt_Domsch at Dell.com
Wed Mar 13 22:50:00 CST 2002


> I am currently running kernel 2.4.2-2smp and need to install a Qlogic
> QLA2200F Fibre Channel Adapter.
> 
> According to the Qlogic docco the driver for the adapter is only
> supported on kernel 2.4.3-12.
> 
> Does anyone know of any problems with upgrading to this kernel?

2.4.3-12 works fine.

> Are there any gotchas to look out for?

Not really.

> Has anyone installed one of this qlogic adapters before?

Sure.

> Does it really
> need kernel 2.4.3-12 ot could I upgrade to the latest smp kernel?

I don't recall how they package their driver.

Newer kernels do exist (2.4.9-31) which have security fixes.  You might also
look at the qla2200 driver already in that kernel.  Arjan @ Red Hat has
spent a lot of time cleaning QLogic's driver.  QLogic is incorporating those
changes back into their next release.  That's what I would look at first.

Thanks,
Matt

-- 
Matt Domsch
Sr. Software Engineer
Dell Linux Solutions www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com
#1 US Linux Server provider for 2001! (IDC Mar 2002)




More information about the Linux-PowerEdge mailing list