Kernel panics on PE6450 and memory>4GB

Stephan Wonczak a0033 at rrz.uni-koeln.de
Tue Mar 12 05:07:00 CST 2002


  Hi!
  I have a problem getting my large memory to work correctly. I am running
RH 7.2 with a 2.4.9-Kernel. Booting with a vanilla SMP kernel works OK,
but then it only has ~3.7G memory available; no problem there, this is how
it is supposed to be. Using an enterprise kernel, which has the 64GB
memory support enabled, the machine fails booting the OS and stops with a
kernel panic. I have tried several kernel versions (both off distribution
disks and self-compiled), but the effect was the same in all instances.
  Now for the curious thing. When I use the mem=xxx boot option, I am able
to use up to 7GB of my main memory (with the very same enterprise kernels 
mentioned above!),which is better than the 3.7G but still not satisfying.
When I go up to 7.5GB, the kernel panics again. Any ideas, anyone?

                Dipl. Chem. Stephan Wonczak
		Institut fuer Angewandte Informatik (ZAIK)
                Regionales Rechenzentrum der Universitaet zu Koeln (RRZK)
                Universitaet zu Koeln
                Robert-Koch-Strasse 10
                50931 Koeln
                Tel: ++49/(0)221/478-5577
		Fax: ++49/(0)221/478-5590




More information about the Linux-PowerEdge mailing list