Top command crashing with floating point exception!

Basil Hussain basil.hussain at kodakweddings.com
Tue Mar 5 11:27:00 CST 2002


Hi,

> Well, that is unless "checksums for the binary" means that you did this
> already--sorry.

Yes, like I said, I've already done this...

> It would be a good idea to verify that binary first.
>
> rpm -vVf $(which top) && echo OK || echo FAILED

I downloaded a fresh copy of top from the procps RPM for RH7.0 from my local
RedHat mirror (www.mirror.ac.uk - they have a great facility to 'browse'
inside RPMs, zips, etc.) onto my Windows desktop, got the MD5 sum of it and
compared it to the one on the server. It matches, so I conclude the binary
is not trojanised.

So, anybody have any ideas why top is suddenly throwing tantrums?

Regards,

Basil Hussain
---------------------------------------
Internet Developer, Kodak Weddings
E-Mail: basil.hussain at kodakweddings.com


> Basil Hussain wrote:
>
> >Hi,
> >
> >Just today, whilst winging my way around a command-line session
> on one of my
> >Linux servers (Dell-installed RH7.0, 2.2.16-enterprise) I ran the 'top'
> >command and receieved, much to my puzzlement, the following error:
> >
> > 12:09pm  up 252 days, 20:29,  1 user,  load average: 0.00, 0.00, 0.00
> >51 processes: 50 sleeping, 1 running, 0 zombie, 0 stopped
> >Floating point exception (core dumped)
> >
> >Why on earth would top crash with such an error? Any specific
> reasons this
> >would happen? I've tried using 'ps', which seems to work fine.
> >
> >By the way, before anyone talks about intrusions, I've already had that
> >thought (with top being trojanised, albeit malfunctioning). I've
> checked all
> >the usuals - checksums for the binary, syslogs (or lack of), unusual
> >listening ports, etc. and nothing is out of the ordinary. So,
> this doesn't
> >appear to be the case. Must be just something ordinary like a bug...
> >
> >Regards,
> >
> >Basil Hussain
> >---------------------------------------
> >Internet Developer, Kodak Weddings
> >E-Mail: basil.hussain at kodakweddings.com





More information about the Linux-PowerEdge mailing list