Top command crashing with floating point exception!

Basil Hussain basil.hussain at kodakweddings.com
Tue Mar 5 10:27:00 CST 2002


Hi,

Just today, whilst winging my way around a command-line session on one of my
Linux servers (Dell-installed RH7.0, 2.2.16-enterprise) I ran the 'top'
command and receieved, much to my puzzlement, the following error:

 12:09pm  up 252 days, 20:29,  1 user,  load average: 0.00, 0.00, 0.00
51 processes: 50 sleeping, 1 running, 0 zombie, 0 stopped
Floating point exception (core dumped)

Why on earth would top crash with such an error? Any specific reasons this
would happen? I've tried using 'ps', which seems to work fine.

By the way, before anyone talks about intrusions, I've already had that
thought (with top being trojanised, albeit malfunctioning). I've checked all
the usuals - checksums for the binary, syslogs (or lack of), unusual
listening ports, etc. and nothing is out of the ordinary. So, this doesn't
appear to be the case. Must be just something ordinary like a bug...

Regards,

Basil Hussain
---------------------------------------
Internet Developer, Kodak Weddings
E-Mail: basil.hussain at kodakweddings.com





More information about the Linux-PowerEdge mailing list