PV110T VS80 tape compression performance

bscott@ntisys.com bscott at ntisys.com
Sat Dec 14 00:02:00 CST 2002


  We just received our first PowerVault 110T VS80 (AKA Benchmark DLT1).  I
have been running some tests on it, and I am seeing some sort of performance
problem whenever I enable compression.  Briefly, if I write to the tape with
compression enabled, the drive stops and restarts constantly, causing
performance to go right into the gutter.  If I disable compression, it
streams well, and I get 2.8 MByte/s, close to the rated maximum.

  To test performance, I have been using two separate tests.  One is to
create a 1 gigabyte test file, filled with the same repeating text pattern.  
I then write that to tape using "tar".  The other test I have been using is
to use "dd" to write from /dev/zero directly to the tape device.  This
second test should eliminate the disk subsystem entirely, but it makes
little difference to tape performance.

  I have tried tuning performance as follows: I added the line

	options st buffer_kbs=128

to the /etc/modules.conf file, to increase the size of the kernel tape
buffer.  I tried setting selected SCSI tape options with mt, as follows:

  	mt stoptions can-bsr fast-eod scsi2logical \
		read-ahead buffer-writes async-writes

Finally, I use a block size of 64 kilobytes when writing to the device with
either tar or dd, like so:

	time dd if=/dev/zero of=/dev/tape bs=64k count=16384

	time tar -c --totals -f /dev/tape -b 128 testfile

None of these performance tweaks appear to help the situation.  I have also
tried accepting the "defaults" without tweaking anything -- same results.

  In both cases, the data consists entirely of repeating patterns -- it
should compress very well.  I am using "mt compression 0" to disable
compression, and "mt compression 1" to enable it.

  The drive identifies itself as a "BNCHMARK DLT1", revision 5032.  The host
system is a PowerEdge 1400, single 1400 MHz CPU, 512 MB RAM.  Operating
system is Red Hat Linux 7.3.  All Red Hat errata updates have been
installed.  Kernel is 2.4.18-18.7.x (uniprocessor).  No other load is
present on the system.  Tape drive is connected to the onboard AIC-7899 SCSI
host adapter.  It is the only device on that adapter.  There are two 36 GB
SCSI disks, mirrored, connected to a PERC 3/SC RAID controller.

  Any ideas?

Ben Scott           | Net Technologies, Inc.  | 978-462-8795
Network Engineer    | Salisbury, MA, USA      | 866-NTI-LINUX (684-5468)
bscott at ntilinux.com | http://www.ntilinux.com | Fax: 978-499-7839

More information about the Linux-PowerEdge mailing list