1650 and VFS: unable to mount root fs

Lars Lindbom Lars.Lindbom at farmbio.uu.se
Thu Dec 5 02:46:01 CST 2002

cc'ing the list, hope that it's ok.

On Wed, 4 Dec 2002, jason andrade wrote:

> well, to be honest it is hard to see what the problem is - i think you're
> doing everything ok.

I waited a long time before I posted to the list of the same reason, I
couldn't see anything that should be wrong. And I've tried a _lot_ of
different approaches on my own as well as talking to Dell's
support here in Sweden. They have some guys that are good at Linux but
they aren't overly enthusiastic about problems with non-RedHat kernels.
But I can understand that, in a way, it's not included in what we've payed
for. Still, the 1650 is 'almost' useless if I can't include it in our
openMOSIX cluster.

> when you see the system coming up - do you see two aic7xxx devices being
> detected ? (you should).
> also, do you see all the scsi disks being detected ?
> eg
> scsi:a
> scsi:b

Well, I think that it never comes to that. I've attached a full dmesg
output from booting from the 2.4.18-17.8.0 RH kernel. A bit of it is
below and the root fs is mounted just before the detection of the scsi

dmesg snip>>
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 245k freed
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
PCI: Assigned IRQ 3 for device 01:06.0
PCI: Assigned IRQ 7 for device 01:06.1
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.8
        <Adaptec aic7899 Ultra160 SCSI adapter>
        aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

scsi1 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.8
        <Adaptec aic7899 Ultra160 SCSI adapter>
        aic7899: Ultra160 Wide Channel B, SCSI Id=7, 32/253 SCBs

blk: queue c24c8a14, I/O limit 4095Mb (mask 0xffffffff)
  Vendor: FUJITSU   Model: MAM3367MC         Rev: 5A01
  Type:   Direct-Access                      ANSI SCSI revision: 03
blk: queue c24c8c14, I/O limit 4095Mb (mask 0xffffffff)
  Vendor: PE/PV     Model: 1x3 SCSI BP       Rev: 0.28
  Type:   Processor                          ANSI SCSI revision: 02
<<end snip

The standard kernels hang just before this, at the
VFS: Mounted root (ext2 filesystem)
I guess.

But what puzzles me is why the kernel mounts the root _before_ the
detection of the scsi-controller and disks (how can it?) and also why it
seems to see the root filesystem as ext2 when in fact it is ext3.

Hasn't anybody else tried building their own 2.4.18, 19 or 20 kernels
from standard source code for a 1650?



Lars Lindbom
Division of Pharmacokinetics and  Therapy
Department of Pharmaceutical Biosciences
Uppsala University

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmesg.txt
Url: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20021205/cc256cbe/dmesg.txt

More information about the Linux-PowerEdge mailing list