1650 and VFS: unable to mount root fs

Lars Lindbom Lars.Lindbom at farmbio.uu.se
Tue Dec 3 15:36:00 CST 2002

Thank you all, Matt, Marco, Jim and Ben for your quick answers.

Unfortunately, I'm still stuck with the same message. I've changed the
"root=" option in grub and in fstab to /dev/sda1 that should be mounted
as / and remade the initrd image. The only change was that it now did not
recognize sda1 or '08:01' whatever that means. I did get the line

kmod: failed to exec /sbin/modprobe -s -k block-major -8, errno = 2

just above the 'VFS: ...' message. I've seen this line before, on a 4600,
but this computer booted fine.

I don't have the PERC3/Di activated in this machine so the aacraid module
is not necessary, right?

I tried another build with aacraid as a module, just as a double-check,
with no success. No aacraid options in /etc/modules.conf.

On Tue, 3 Dec 2002 bscott at ntisys.com wrote:
>   Does the kernel find your root device during initialization?  That is,
> does it find your disk controller and enumerate your root disk?

Do you mean like this:?

scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
        <Adaptec aic7899 Ultra160 SCSI adapter>
        aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

This is from a 4600 and it is the step I would like to see just after the
init process has mounted the root file-system. Or do you mean something
before this?

I have compiled a few kernels before but I feel totally lost here. I have
tried to go from the RedHat kernels, disabling module by module to see if
I could get the same message or symptoms but I virtually could disable
everything but the modules that I mentioned in my first post.


Lars Lindbom
Division of Pharmacokinetics and  Therapy
Department of Pharmaceutical Biosciences
Uppsala University

More information about the Linux-PowerEdge mailing list