Openmanage/IT Assistant and Linux

Joshua_Giles@Dell.com Joshua_Giles at Dell.com
Thu Aug 29 15:18:01 CDT 2002


The man page on snmpd.conf is your friend here.  But, basically you need to
change the conf file to allow access to certain IP's using a non-trivial
community name(i.e. public).  This site might is also a good help for
understandning simple security configurations in snmpd.conf:
http://www.onlamp.com/pub/a/bsd/2000/08/10/Big_Scary_Daemons.html



Joshua Giles
Linux Operating System Development
"I don't suffer from insanity but enjoy every minute of it "
- Edgar Allan Poe




-----Original Message-----
From: Ed Griffin [mailto:edg at ll.mit.edu]
Sent: Thursday, August 29, 2002 2:53 PM
To: Joshua_Giles at exchange.dell.com
Subject: RE: Openmanage/IT Assistant and Linux


Does that give everyone write access or only the administrative user that 
logs in with the root/calvin combination?  I would hate to give the world 
write access.  Thanks for the info.

--Ed

At 02:01 PM 8/29/2002 -0500, you wrote:

>I think I know what the problem is.  Try changing the following line in the
>/etc/snmp/snmpd.conf file
>
>From:
>#group          context sec.model sec.level prefix read   write  notif
>access  notConfigGroup ""      any       noauth    exact  all    none
none
>
>To:
>#group          context sec.model sec.level prefix read   write  notif
>access  notConfigGroup ""      any       noauth    exact  all    all   none
>
>Then restart the snmpd, and dellomsa services.
>
>This gives the "all" view that is created by Administrator in your
>snmpd.conf file, write access.  As you can see from the commented line, the
>7th field controls write access and by default the rpms that install
>Administrator do not enable write access for security reasons.
>
>Read ya,
>
>Joshua Giles
>Linux Operating System Development
>
>
>
>-----Original Message-----
>From: Ed Griffin [mailto:edg at ll.mit.edu]
>Sent: Thursday, August 29, 2002 10:05 AM
>To: Joshua_Giles at exchange.dell.com; linux-poweredge at exchange.dell.com
>Subject: RE: Openmanage/IT Assistant and Linux
>
>
>I tried that, I still get "Unable to login to the specified system",  Is
>there any Linux specific documentation for Openmanage?  I can log into IT
>Assistant no problem, but when I try to access anything on the client Linux
>2650, I get the above listed error.  I can see anything that is read-only
>access, fan speeds, temperatures, etc, but if I try to change the
>thresholds for example, I get a dialog box prompting for a username and
>password and then the error.
>
>The client server is running Redhat 7.3, kernel 2.4.18-10smp, all available
>patches as of yesterday and the latest version of Server Administrator
>available from Dell.  I did find a reference to this error, that it could
>be caused if SNMP isn't configured for read-write access, but unfortunately
>I am not all that familiar with SNMP to know whether or not this is the
>case, I was relying on Dell's install to take care of this for me... :)
>
>
>--Ed
>
>At 09:38 AM 8/29/2002 -0500, Joshua_Giles at Dell.com wrote:
> >ITA's defaults are:
> >
> >username:root
> >password:calvin
> >
> >Thanks,
> >
> >Joshua Giles
> >Linux Operating System Development
> >
> >
> >
> >-----Original Message-----
> >From: Ed Griffin [mailto:edg at ll.mit.edu]
> >Sent: Wednesday, August 28, 2002 10:31 AM
> >To: linux-poweredge at exchange.dell.com
> >Subject: Openmanage/IT Assistant and Linux
> >
> >
> >I installed the latest version of Server Administrator on my PE2650 and I
> >installed IT Assistant on my Dell Workstation.  When I try to access the
> >2650 in anything that requires a read/write mode, I get a dialog box that
> >pops up to login.  When I type in root and any password, unless this is
one
> >I do not know, I have tried my root password, the default Dell root
> >password for the ERA card, I even tried logging into server administrator
> >and setting the SNMP root password, I get an error that the IT Assistant
> >cannot log into the server.  Does anyone know what I am doing wrong?  Did
I
> >miss something in the setup or is this extended functionality not
supported
> >by Linux?  I have been playing with Dell servers and Linux for quite a
> >while, but this is my first attempt at OpenManage in any way shape or
> >form.  Thanks for any help.
> >
> >--Ed
> >
> >
> >
> >
> >*****************************************************************
> >Ed Griffin
> >Assistant Network/System Administrator
> >MIT Lincoln Laboratory - Weather Sensing
> >Phone:    (781) 981-2871
> >mailto:edg at ll.mit.edu
> >*****************************************************************
> >
> >_______________________________________________
> >Linux-PowerEdge mailing list
> >Linux-PowerEdge at dell.com
> >http://lists.us.dell.com/mailman/listinfo/linux-poweredge
> >Please read the FAQ at http://lists.us.dell.com/faq or search the list
> >archives at http://lists.us.dell.com/htdig/





More information about the Linux-PowerEdge mailing list