Tape device unrecognized on PE1650 external SCSI

Jonathan Delgado delgado at molbio.mgh.harvard.edu
Wed Aug 28 11:29:01 CDT 2002


Hi,
    I have a fresh out of the box PowerEdge 1650 with the PERC 3/Di 
controller, which came with a factory-installed RH 7.3 build on it. I 
have attached to the external SCSI interface an HP Ultrium 215 tape 
array module. The mechanism shows up if I go into the Disk Utilities 
built in to the SCSI controller at boot time (via Control-A), however 
there is no sign of the device getting loaded in the boot messages and 
as a result I have no /dev/st0.

    Snippit from dmesg for SCSI stuff is just as follows:

SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Red Hat/Adaptec aacraid driver, May  2 2002
scsi0 : percraid
   Vendor: DELL      Model: PERCRAID Mirror   Rev: 0001
   Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 71091456 512-byte hdwr sectors (36399 MB)
sda: Write Protect is off
Partition check:
  sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 sda9 >

    FWIW, I applied the v2.7.1 firmware update with no change in results. 
Unfortunately I have no other external SCSI devices that I can try in 
it's place to confirm that RH is even looking at the external channel on 
the controller.

    I am near my wit's end on this. SCSI tape support is set with module 
support. I have tried manually loading the module to no avail, likewise 
I have tried manually adding the device by echoing 'scsi 
add-single-device...' to /proc/scsi/scsi with no luck.

    Has anyone seen behavior like this before? Am I missing some other 
important updates? Any pointers would be much appreciated. Thank you.

-Jonathan
--
Jonathan Delgado, Systems Manager
Massachusetts General Hospital
Department of Molecular Biology: Bioinformatics Group & DNA Core




More information about the Linux-PowerEdge mailing list