problem with Megaraid + Adaptec and device names

Brian Gibson bgibson at wheatonma.edu
Thu Aug 15 12:10:01 CDT 2002


Thank you both for helping me out with this....it works like a charm.

I had originally called Dell on this a long time ago but they had no answer.


Steve_Boley at Dell.com wrote:

>You did right when you rearranged the controllers in modules.conf but you
>missed a step after that, you have to redo your ram disk images with
>mkinitrd or it just keeps loading controllers in the same order as before.
>Use the mv command to rename the initrd of your main booting kernel and then
>use #mkinitrd inintrd-2.4.18-7.80.img 2.4.18-7.80 and it will redo the
>ramdisk with the scan order for loading the controllers rearranged and no
>more problems.  Do only one of your boot kernel options so that you can
>still boot back up if you make a mistake and after you get it working right
>you can do the rest of them as well.  Make sure you move the megaraid module
>to the top and remember the first has no number and then the next subsequent
>one aic7xxx will be scsi_host adapter1 and so on.  Attaching text file I
>wrote about this type of issue.
>Steve
>
>-----Original Message-----
>From: Brian Gibson [mailto:bgibson at wheatonma.edu]
>Sent: Thursday, August 15, 2002 8:53 AM
>To: linux-poweredge at exchange.dell.com
>Cc: dtice at wheatonma.edu; Matthew Burch
>Subject: problem with Megaraid + Adaptec and device names
>
>
>Hello all,
>
>We have a brand new Dell Poweredge 2550 with an onboard 2 channel 
>Adaptec SCSI card (7890 I believe) and a PCI MegaRaid card. The Megaraid 
>card has 2 channels and off of channel A there is a mirrored set. When 
>we install RedHat to the partitions on the mirrored set everything works 
>fine, that set is considered /dev/sda.
>
>We have 2 external raid enclosures from a company called Zzyzx that we 
>want to connect to the on board Adaptec card so we purchased a PCI slot 
>cover that has a SCSI interface and a cable that connectes to the 
>internal channel A on the SCSI card. When we boot up the system, the 
>Adaptec card recognizes the device(s) at bootup and starts loading linux 
>from the MegaRaid card just like before. The problem is the boot up 
>hangs about halfway through because one of the external RAID enclosures 
>becomes /dev/sda and the mirrored drives that are off the MegaRaid card 
>end up beconing /dev/sdc
>
>This is what I have tried.....
>
>1. Installing an Adaptect 2940 PCI card and running those external 
>drives off of it (still no luck).
>
>2. Moving the Adaptec 2940 PCI card up above and below the MegaRaid card 
>thinking that it might change the order in which the drivers come up 
>(still no luck).
>
>3.  Finding the megaraid driver in /etc/modules.conf and moving its 
>placement around in that file (still no luck).
>
>4.  Fooled around with the "map-drive" option in /etc/lilo.conf (still 
>no luck).
>
>5.  The BIOS is disabled on both of the Adaptect cards (but that 
>shouldn't mattter since it does initially boot from the MegaRaid 
>mirrored set.)
>
>6. I tried using Dell's  Server Assistant CD to facilitate the RedHat 
>7.2 install (still no luck).
>
>There are two ways we can get around this and one is somewhat acceptable 
>and the other is not recommended and I believe we take a performance hit.
>
>1. We bought a mini-centronics scsi cable and can run external SCSI 
>devices off of channel B on the MegaRaid card externally, they do come 
>up as /dev/sdb and /dev/sdc (this was tested with a few cheap older 
>external drives, not with the external RAID arrays.... Zzyzx says that 
>they do not recommend this and will not support it because you are 
>doubling up on the RAID.)
>
>2.  We could install the OS with the two external Raid Arrays attached 
>and they can become /dev/sda  and /dev/sdb but.... if one of those fails 
>at any point you have lost the OS.
>
>Any help on this issue would be greatly appreciated.
>
>Thanks,
>Brian Gibson
>Systems Administrator
>Wheaton College
>
>_______________________________________________
>Linux-PowerEdge mailing list
>Linux-PowerEdge at dell.com
>http://lists.us.dell.com/mailman/listinfo/linux-poweredge
>Please read the FAQ at http://lists.us.dell.com/faq or search the list
>archives at http://lists.us.dell.com/htdig/
>
>
>------------------------------------------------------------------------
>
>PowerEdge with RedHat Linux and Perc2, 2/si, 3/si, and 3/di has 
>Kernel Panic After Configuring Logical Drive on PVXXX Attached to Megaraid Perc
>
>System boots fine with both the ROMB and AMI percs in the system but once
>a logical drive is configured on the AMI perc, kernel panics happen
>until the logical drive is deleted on the AMI/LSI Megaraid controller.
>
>The problem is with Redhat Linux's method of scanning the pci bus.  It is scanning
>the pci slots before the embedded controllers and is loading the megaraid module
>before the aacraid module and subsequently rearranges the drive and partition
>order on the system and then grub/lilo points to the wrong location for the root
>partition of the system.  The fix is to edit your /etc/modules.conf to reflect
>the order the modules should actually be loaded and then recreating your system
>ramdisks to properly load the modules when the kernel is booting.  Here are the 
>steps necessary to do that:
>
>1.  You need to disconnect the external drives and boot the system. Edit your
>/etc/modules.conf file. You should see lines like:
>
>          scsi_hostadapter  megaraid
>          scsi_hostadapter1 aacraid
>          scsi_hostadapter2 aic7xxx
>
>and possibly others. Re-arrange the lines so that "aacraid" is before all the rest, 
>and renumber them in the new order.  What's important is that aacraid is first:
>           scsi_hostadapter  aacraid
>           scsi_hostadapter1 aic7xxx
>           scsi_hostadapter2 megaraid
>
>2.  Next, you need to regenerate all of your initial ramdisks (initrds). The command 
>to do this is:
>#mkinitrd  initrd-filename  kernel-version
>Example for 7.2 default kernel is:
>#mkinitrd /boot/initrd-2.4.7-10smp.img 2.4.7-10smp
>
>Do this only on one kernel at first to ensure that you do it properly and can boot to
>the kernel that you have created the ramdisk for.  After successfully booting to the
>kernel with the new ramdisk, then continue to create ramdisks for all your kernels you
>have listed in /etc/lilo.conf or /boot/grub/grub.conf.
>
>You are now ready to reattach the PVxxx and recover the configuration from NVRAM or
>if no array is there, create a logical drive, initialize, and boot to linux.
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20020815/3887c140/attachment.htm


More information about the Linux-PowerEdge mailing list