problem with Megaraid + Adaptec and device names

Brian Gibson bgibson at wheatonma.edu
Thu Aug 15 08:54:00 CDT 2002


Hello all,

We have a brand new Dell Poweredge 2550 with an onboard 2 channel 
Adaptec SCSI card (7890 I believe) and a PCI MegaRaid card. The Megaraid 
card has 2 channels and off of channel A there is a mirrored set. When 
we install RedHat to the partitions on the mirrored set everything works 
fine, that set is considered /dev/sda.

We have 2 external raid enclosures from a company called Zzyzx that we 
want to connect to the on board Adaptec card so we purchased a PCI slot 
cover that has a SCSI interface and a cable that connectes to the 
internal channel A on the SCSI card. When we boot up the system, the 
Adaptec card recognizes the device(s) at bootup and starts loading linux 
from the MegaRaid card just like before. The problem is the boot up 
hangs about halfway through because one of the external RAID enclosures 
becomes /dev/sda and the mirrored drives that are off the MegaRaid card 
end up beconing /dev/sdc

This is what I have tried.....

1. Installing an Adaptect 2940 PCI card and running those external 
drives off of it (still no luck).

2. Moving the Adaptec 2940 PCI card up above and below the MegaRaid card 
thinking that it might change the order in which the drivers come up 
(still no luck).

3.  Finding the megaraid driver in /etc/modules.conf and moving its 
placement around in that file (still no luck).

4.  Fooled around with the "map-drive" option in /etc/lilo.conf (still 
no luck).

5.  The BIOS is disabled on both of the Adaptect cards (but that 
shouldn't mattter since it does initially boot from the MegaRaid 
mirrored set.)

6. I tried using Dell's  Server Assistant CD to facilitate the RedHat 
7.2 install (still no luck).

There are two ways we can get around this and one is somewhat acceptable 
and the other is not recommended and I believe we take a performance hit.

1. We bought a mini-centronics scsi cable and can run external SCSI 
devices off of channel B on the MegaRaid card externally, they do come 
up as /dev/sdb and /dev/sdc (this was tested with a few cheap older 
external drives, not with the external RAID arrays.... Zzyzx says that 
they do not recommend this and will not support it because you are 
doubling up on the RAID.)

2.  We could install the OS with the two external Raid Arrays attached 
and they can become /dev/sda  and /dev/sdb but.... if one of those fails 
at any point you have lost the OS.

Any help on this issue would be greatly appreciated.

Thanks,
Brian Gibson
Systems Administrator
Wheaton College




More information about the Linux-PowerEdge mailing list