SUMMARY - Non-RAID PE2650 SCSI problem

David Borg-Breen breen at pmel.noaa.gov
Wed Aug 7 15:26:00 CDT 2002


Many thanks to Matt Domsch and Jason Andrade.

Matt Domsch gave me the final solution below.

-David Borg-Breen



> Subject:     RE: Non-RAID PE2650 SCSI problem
> Date:        Tue, 06 Aug 2002 20:09:49 -0500
> From:        <Matt_Domsch at Dell.com>
> To:          breen at pmel.noaa.gov, linux-poweredge at dell.com
> 
> 
> 
> 
> > We have a PE 2650 with embedded AIC 7899 and 2 additional
> > 39160s - with RedHat 7.2 pre-installed by DELL.
> >
> > The system works fine with the 2 DELL-installed internal
> > disks connected
> > to the 7899 - but gets a "kernel panic" trying to boot if I attach an
> > external SCSI disk to either of the 39160s.
> 
> You've got to re-make the initial ramdisk, with the following in
> /etc/modules.conf:
> 
> alias scsi_hostadapter aic7xxx
> options aic7xxx aic7xxx=reverse_scan:1
> 
> 
> The 39160 card is getting picked up first by the aic7xxx driver - you need
> the onboard chips to get picked up first.  Make that change, then remake
> your initial ramdisk, and you'll be fine.
> 
> Thanks,
> Matt
> 
> --
> Matt Domsch
> Sr. Software Engineer, Lead Engineer, Architect
> Dell Linux Solutions www.dell.com/linux
> Linux on Dell mailing lists @ http://lists.us.dell.com
> #1 US Linux Server provider for 2001 and Q1/2002! (IDC May 2002)
> 






Original post:

> Subject:     Non-RAID PE2650 SCSI problem
> Date:        Tue, 06 Aug 2002 17:08:54 -0700
> From:        David Borg-Breen <breen at pmel.noaa.gov>
> To:          linux-poweredge at dell.com
> 
> Hi -
> 
> 
> I would expect this would be obvious - but DELL's tech-support still
> doesn't have an answer for me - even after purchasing "Direct Line Plus"
> incident help.
> 
> We have a PE 2650 with embedded AIC 7899 and 2 additional 39160s - with
> RedHat 7.2 pre-installed by DELL.
> 
> The system works fine with the 2 DELL-installed internal disks connected
> to the 7899 - but gets a "kernel panic" trying to boot if I attach an
> external SCSI disk to either of the 39160s.  I've tried this with different
> disks - all of which work fine on other Sun or Compaq Unix boxes.
> 
> It appears the 2650 is trying to boot from the external disk.
> 
> 
> /etc/modules.conf contained the single scsi_hostadapter entry:
> 
>     alias scsi_hostadapter aic7xxx
> 
> DELL-support had me try a couple variations with modules.conf - but
> nothing has worked so far.
> 
> We installed RedHat updates - resulting in a kernel upgrade from
> 2.4.7-10smp to 2.4.9-34smp - but nothing changed.
> 
> Unfortunately I'm relatively new to RedHat and DELL (more experience
> with other Unixes).
> 
> Help - can anyone suggest a solution?
> 
> 
> Thanks in advance.
> 
> -David Borg-Breen
>




More information about the Linux-PowerEdge mailing list