2550 interrupts?

Tom Hoffman thomas.e.hoffman at verizon.net
Wed Aug 7 02:12:01 CDT 2002


Hello,

I received my first real server a few days ago (for our high school's web 
server), a 2550 with the perc 3 and three drives in RAID 5, RedHat 7.2 
preinstalled.  I do have extensive experience with Linux on pc's and Mac's.  

I know that I probably can't get a definitive answer to my problems until I do 
the whole null modem thing and capture my error logs, but in the meantime, 
please humor me.

The 2550 locked up and/or crashed with some regularity, especially when I ran 
iozone to benchmark the drives.  I discovered this list and Matt's excellent 
site last night and decided the next course of action would be to just try 
installing RedHat 7.3, rather than messing around with upgrading bits of 7.2.

I managed to substantially sidetrack myself today by trying to divide my disk 
into three containers, as someone suggested on this list, so that I could 
have my (Zope) database on a separate container.  I also decided that it 
would be a bright idea to make a striped container for my swap partition, to 
make it faster (although hopefully I won't be using it much...).  

After that, I couldn't get the database containter (it is RAID 5) to format in 
the installer.  The installer would just stop and tell me that there was a 
serious problem with the drive.  The other containers worked fine.  I think 
this is because I had inadvertantly interrupted the "clean" process when I 
created the container.  So I recreated the container, and just before the 
janitors locked up the building, I ran the 7.3 installer again.  

It seemed to be formatting the troublesome container properly (little progress 
bar moving along...) until I got a huge stream of error code ending with (I 
wrote it down):

Code: Bad EIP value
<o> Kernel panic:  Aiee, killing interrupt handler
In interrupt handler - not syncing

I had seen this error message before, as well.

When I look at the interrupts under BIOS, it doesn't look right, but I don't 
understand interrupts:

SLOT 1: Adaptec SCSI Adapter: IRQ 11
SLOT 1: Adaptec SCSI Adapter: IRQ 10
SLOT 3: Broadcom Corp Adapter: IRQ 5
Embedded Broadcom Corp 10/100/1000 NIC: IRQ 11
Embedded Dell RAID Adapter: IRQ 5
Embedded Intel Corp 10/100 NIC: IRQ 10
Embedded Adaptec SCSI Adapter: IRQ 5
Embedded Adapted SCSI Adapter: IRQ 11

Does that look right?

So the questions are 
1) is making a mix of Striped and RAID 5 containers a bad idea or is there a 
trick to making it work (or is this generally not a problem)?
2) is there something obviously wrong with my interrupts?
3) should I do something other than keep trying to get 7.3 to install and try 
to capture some core dumps?

Thanks!

--Tom




More information about the Linux-PowerEdge mailing list