New to RAID/Linux - PE2650, Redhat 7.3

Seth Mos knuffie at xs4all.nl
Mon Aug 5 07:38:01 CDT 2002


At 08:13 5-8-2002 -0400, Brian K. Jones wrote:
>Hi all,
>
>I have a PE2650 with the PERC3/Di RAID controller and an Adaptec 7899
>SCSI card.  I'm running Redhat 7.3 (stock SMP kernel for now).  I don't
>really know how lost I am, quite honestly, but what's happening is that
>it *appears* that the aacraid driver is loaded upon bootup, but when I
>run 'lsmod', aacraid is not listed.  Compounding this issue is the fact
>that I have no idea what arguments to give the module to load it.  It's
>also not listed in /etc/modules.conf.

Just putting the module into /etc/modules.conf should do the trick and 
kudzu should detect this automatically.

>I installed the kernel docs and source, but the README that came with
>the driver are really of absolutely no use in getting me started.
>
>My impression (which I admit may be wrong, at best) is that setting up
>raid upon install with Redhat uses *software* RAID, but I should think
>the hardware RAID would be much more reliable, not to mention faster.

Opinions on this vary. In my opinion software raid is just as fast and 
reliable as hardware raid. In most cases software raid is even faster then 
hardware raid.

I like software raid and it does what it is supposed to do. So far it 
already saved me from 2 diskfailures. No dataloss to date.

>I'd like to use the hardware to run RAID 0 - I only have two disks, so I
>just wanna mirror the root disk.

Raid 0 is striping not mirroring. Raid 1 is what you want.

Cheers

--
Seth
It might just be your lucky day, if you only knew.




More information about the Linux-PowerEdge mailing list