<div dir="ltr">Nigel,<div><br></div><div>I ran into this problem as well and found in some cases I had to reseat the affected node to get the bmc to reset. I haven&#39;t seen this issue since BMC firmware 1.15. In all cases I was eventually able to get the firmware flashed, but it did seem to be much more likely to succeed if I ran ipmiflash on the host rather than on another host flashing over the network. If all else fails, I had 100% success running the firmware .BIN files after booting from the OMSA Live CD. It&#39;s annoying to physically go to each host, but it worked. </div>
<div><br></div><div>jbh</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Mar 5, 2014 at 7:00 PM, Nigel Williams <span dir="ltr">&lt;<a href="mailto:Nigel.Williams@utas.edu.au" target="_blank">Nigel.Williams@utas.edu.au</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">





<div lang="EN-AU" link="blue" vlink="purple">
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">That all went ok, but the ipmiflash tool appeared to be stuck in the Transmitting phase (I waited 15 minutes for cancelling it) and now of course the BMC is
 stuck in update mode, but for some reason this command:<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">[root@SomeHost pec]# ipmitool bmc reset cold<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">Failed to do cold reset to MC<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">Is failing, am I doing something wrong with that command? I notice that attempting to install the BMC tool fails with a dependency regarding OpenIPMI-tools
 (the fault was reported early last year but does not appear to be have been fixed).<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d"><u></u> <u></u></span></p>
<div style="border:none;border-left:solid blue 1.5pt;padding:0cm 0cm 0cm 4.0pt">
<div>
<div style="border:none;border-top:solid #b5c4df 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span lang="EN-US" style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;">From:</span></b><span lang="EN-US" style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;"> <a href="mailto:poweredgec-tools-bounces@dell.com" target="_blank">poweredgec-tools-bounces@dell.com</a> [mailto:<a href="mailto:poweredgec-tools-bounces@dell.com" target="_blank">poweredgec-tools-bounces@dell.com</a>]
<b>On Behalf Of </b>John Hanks<br>
<b>Sent:</b> Thursday, 6 March 2014 11:44 AM<br>
<b>To:</b> <a href="mailto:Poweredgec-tools@dell.com" target="_blank">Poweredgec-tools@dell.com</a></span></p><div class=""><br>
<b>Subject:</b> Re: [Poweredgec-tools] BMC firmware update error on C6145<u></u><u></u></div><p></p>
</div>
</div>
<p class="MsoNormal"><u></u> <u></u></p>
<div>
<p class="MsoNormal">This has been discussed on the list a few times, but when I wen searching for something I didn&#39;t find any condensed answer. Here&#39;s what I did to get the firmware out.<u></u><u></u></p>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">sh C6145_blahblah.BIN --extract ./firmware<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
</div>
</div>
</div>
</div>

<br>_______________________________________________<br>
Poweredgec-tools mailing list<br>
<a href="mailto:Poweredgec-tools@dell.com">Poweredgec-tools@dell.com</a><br>
<a href="https://lists.us.dell.com/mailman/listinfo/poweredgec-tools" target="_blank">https://lists.us.dell.com/mailman/listinfo/poweredgec-tools</a><br>
<br></blockquote></div><br></div>