<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 14 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:"Lucida Console";
        panose-1:2 11 6 9 4 5 4 2 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1F497D">Hmm...on an R720 and RHEL 5.7 I get:<o:p></o:p></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;"># omreport chassis<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Health<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;;color:black;background:black;mso-highlight:black"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Main System Chassis<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;;color:black;background:black;mso-highlight:black"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">SEVERITY : COMPONENT<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Fans<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Intrusion<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Memory<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Critical : Power Supplies<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Power Management<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Processors<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Temperatures<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Voltages<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Hardware Log<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Batteries<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;;color:black;background:black;mso-highlight:black"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.0pt;font-family:&quot;Lucida Console&quot;">For further help, type the command followed by -?<span style="color:black;background:black;mso-highlight:black"><o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1F497D"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1F497D"><o:p>&nbsp;</o:p></span></p>
<div style="border:none;border-left:solid blue 1.5pt;padding:0in 0in 0in 4.0pt">
<div>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in">
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;">From:</span></b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;"> linux-poweredge-bounces@dell.com [mailto:linux-poweredge-bounces@dell.com]
<b>On Behalf Of </b>Ray Robert<br>
<b>Sent:</b> Wednesday, July 18, 2012 12:56 PM<br>
<b>To:</b> Phillippe Welsh<br>
<b>Cc:</b> linux-poweredge@dell.com<br>
<b>Subject:</b> Re: OMSA - Alerts and Notifications<o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
<p class="MsoNormal" style="margin-bottom:12.0pt">Interesting.&nbsp; On new 720s (CentOS 5) I get:<o:p></o:p></p>
<div style="margin-left:30.0pt">
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-family:&quot;Courier New&quot;">-sh-3.2$ omreport chassis<br>
Error! Hardware or Feature Not Present.<br>
<br>
-sh-3.2$ omreport -?<br>
<br>
omreport&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Reports component properties.<br>
<br>
The available command(s) are:<br>
<br>
Command&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Description<br>
about&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Product and version properties.<br>
preferences&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Report system preferences.<br>
system&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System component properties.<br>
storage&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Display storage component properties.<br>
<br>
Usage: omreport &lt;command...&gt; [name=value...] ... [option...]</span><br>
<br>
<span style="font-family:&quot;Courier New&quot;">-sh-3.2$ rpm -qa srvadmin-omacore<br>
srvadmin-omacore-7.0.0-4.168.1.el5</span><o:p></o:p></p>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-family:&quot;Courier New&quot;"><br>
</span>What was interesting is that OMSA 6.5 on the same boxes did report on chassis, and the GUI on port 1311 still does.<br>
<br>
After seeing your note I tried it on a 2850.&nbsp; Same thing.&nbsp; On version 6.5:<o:p></o:p></p>
<div style="margin-left:30.0pt">
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-family:&quot;Courier New&quot;">-sh-3.2$ omreport chassis<br>
Health<br>
<br>
Main System Chassis<br>
<br>
SEVERITY : COMPONENT<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Fans<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Intrusion<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Memory<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Power Supplies<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Power Management<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Processors<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Temperatures<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Voltages<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Hardware Log<br>
Ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; : Batteries<br>
<br>
For further help, type the command followed by -?<br>
<br>
-sh-3.2$ rpm -qa srvadmin-omacore<br>
srvadmin-omacore-6.5.0-1.143.3.el5<o:p></o:p></span></p>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt">On Version 7:<o:p></o:p></p>
<div style="margin-left:30.0pt">
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-family:&quot;Courier New&quot;">-sh-3.2$ omreport chassis<br>
Error! Hardware or Feature Not Present.<br>
<br>
-sh-3.2$ rpm -qa srvadmin-omacore<br>
srvadmin-omacore-7.0.0-4.168.1.el5<o:p></o:p></span></p>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt">So is this a CentOS 5 issue?<br>
<br>
-- <br>
Ray Robert | Linux Administrator<br>
503.284.7581 ext 242 | <a href="mailto:ray.robert@rentrak.com">ray.robert@rentrak.com</a><br>
RENTRAK | <a href="http://www.rentrak.com/">www.rentrak.com</a> | NASDAQ: RENT<br>
<br>
Notice: This message is confidential and is intended only for the recipient(s) named above. If you have received this message in error, or are not the named recipient(s), please immediately notify the sender and delete this message.<o:p></o:p></p>
<div>
<p class="MsoNormal">On Wed, Jul 18, 2012 at 9:34 AM, Phillippe Welsh &lt;<a href="mailto:pjwelsh@gmail.com">pjwelsh@gmail.com</a>&gt; wrote:<o:p></o:p></p>
<p class="MsoNormal"><br>
----- Original Message -----<br>
<br>
Sorry about the formatting issue...<br>
Date: Wed, 18 Jul 2012 09:15:34 -0700<br>
From: Ray Robert &lt;<a href="mailto:ray.robert@rentrakmail.com">ray.robert@rentrakmail.com</a>&gt;<br>
Subject: Re: OMSA - Alerts and Notifications<br>
To: Helmut Wollmersdorfer &lt;<a href="mailto:helmut.wollmersdorfer@fixpunkt.de">helmut.wollmersdorfer@fixpunkt.de</a>&gt;<br>
Cc: <a href="mailto:linux-poweredge@dell.com">linux-poweredge@dell.com</a><br>
Message-ID:<br>
&lt;CAHERJQ8&#43;&#43;&#43;=<a href="mailto:JASSUKHb4C_xDX%2BscihLT1aWJNdgC1Xb_jjBz0w@mail.gmail.com">JASSUKHb4C_xDX&#43;scihLT1aWJNdgC1Xb_jjBz0w@mail.gmail.com</a>&gt;<br>
Content-Type: text/plain; charset=&quot;iso-8859-1&quot;<o:p></o:p></p>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
A nice plugin. But it depends on omreport. Omreport's &quot;chassis&quot; option is<br>
missing in 7.0, at least in the RPMs posted at<br>
<a href="http://linux.dell.com/repo/hardware/latest/">http://linux.dell.com/repo/hardware/latest/</a>. Or am I the only one getting<br>
that result?<br>
<br>
<o:p></o:p></p>
</div>
<p class="MsoNormal">An old test box looks OK with omreport:<br>
<br>
[root@hmas1 ~]# rpm -qf `which omreport`<br>
srvadmin-omacore-7.0.0-4.168.1.el6.x86_64<br>
<br>
<br>
[root@hmas1 ~]# getSystemId<br>
Libsmbios version: &nbsp; &nbsp; &nbsp;2.2.27<br>
Product Name: &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; PowerEdge 840<br>
Vendor: &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Dell Computer Corporation<br>
BIOS Version: &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; A08<br>
System ID: &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;0x01E7<br>
...<br>
<br>
[root@hmas1 ~]# omreport chassis<br>
Health<br>
<br>
Main System Chassis<br>
<br>
SEVERITY : COMPONENT<br>
Ok &nbsp; &nbsp; &nbsp; : Fans<br>
Ok &nbsp; &nbsp; &nbsp; : Intrusion<br>
Ok &nbsp; &nbsp; &nbsp; : Memory<br>
Ok &nbsp; &nbsp; &nbsp; : Power Supplies<br>
Ok &nbsp; &nbsp; &nbsp; : Processors<br>
Ok &nbsp; &nbsp; &nbsp; : Temperatures<br>
Ok &nbsp; &nbsp; &nbsp; : Voltages<br>
Ok &nbsp; &nbsp; &nbsp; : Hardware Log<o:p></o:p></p>
<div>
<div>
<p class="MsoNormal"><br>
_______________________________________________<br>
Linux-PowerEdge mailing list<br>
<a href="mailto:Linux-PowerEdge@dell.com">Linux-PowerEdge@dell.com</a><br>
<a href="https://lists.us.dell.com/mailman/listinfo/linux-poweredge">https://lists.us.dell.com/mailman/listinfo/linux-poweredge</a><o:p></o:p></p>
</div>
</div>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
<br>
<br>
<o:p></o:p></p>
</div>
</div>
</body>
</html>