[Linux-PowerEdge] RHEL 8.x dell-system-update RPM should include libssh2 RPM as a dependency...

Patrick Boutilier boutilpj at ednet.ns.ca
Fri Feb 21 13:21:53 CST 2020


[EXTERNAL EMAIL] 

Works for me.


[root at vs lib64]# dsu -v
DELL EMC System Update 1.7.0
Copyright (C) 2014 DELL EMC Proprietary.

[root at vs lib64]# ldd /usr/sbin/dsu|grep libssh
         libssh.so.4 => /lib64/libssh.so.4 (0x00007fe5110ea000)





On 2/21/20 3:00 PM, Chris Adams wrote:
> 
> [EXTERNAL EMAIL]
> 
> libssh is a completely different library from libssh2, so that's not
> going to work.
> 
> libssh2 has been deprecated in RHEL 8.1 in favor of libssh - libssh2
> _may_ get added to EPEL, but it has not so far.  Dell should probably
> look at either updating their code to use the alternate, or they could
> include libssh2 in their RHEL 8 repo.
> 
> Once upon a time, Patrick Boutilier <boutilpj at ednet.ns.ca> said:
>>
>> [EXTERNAL EMAIL]
>>
>> Or just make a symbolic link.
>>
>>
>>
>> cd /usr/lib64
>>
>> ln -s libssh.so.4 libssh2.so.1
>>
>>
>> On 2/21/20 1:05 PM, Aram Mirzadeh wrote:
>>> I downloaded libssh from github and compiled it.  I just needed
>>> the regular "Development Tools" group install.
>>>
>>> On Fri, Feb 21, 2020 at 11:47 AM <Spike.White at dell.com
>>> <mailto:Spike.White at dell.com>> wrote:
>>>
>>>     All,____
>>>
>>>     __ __
>>>
>>>     On RHEL8.1, when installing dell-system-update RPM as per usual
>>>     instructions, dsu fails on the command line as so:____
>>>
>>>     __ __
>>>
>>>     [root at austgcore17 ~]# dsu --help____
>>>
>>>     dsu: error while loading shared libraries: libssh2.so.1: cannot open
>>>     shared object file: No such file or directory____
>>>
>>>     __ __
>>>
>>>     It’s trivial to fix, just install the libssh2 RPM:____
>>>
>>>     __ __
>>>
>>>     [root at austgcore17 ~]# yum -y install libssh2____
>>>
>>>     …____
>>>
>>>     [root at austgcore17 ~]# dsu --help____
>>>
>>>     __ __
>>>
>>>     Usage: dsu [OPTION]...____
>>>
>>>              Options:____
>>>
>>>              …____
>>>
>>>     __ __
>>>
>>>     However, for completeness the dell-system-update RPM for RHEL8
>>>     should add libssh2 RPM as an RPM dependency.____
>>>
>>>     __ __
>>>
>>>     Spike____
>>>
>>>     _______________________________________________
>>>     Linux-PowerEdge mailing list
>>>     Linux-PowerEdge at dell.com <mailto:Linux-PowerEdge at dell.com>
>>>     https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>>>
>>>
>>> _______________________________________________
>>> Linux-PowerEdge mailing list
>>> Linux-PowerEdge at dell.com
>>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>>>
> 
>> begin:vcard
>> fn:Patrick Boutilier
>> n:Boutilier;Patrick
>> org:;Nova Scotia Department of Education
>> adr:;;2021 Brunswick Street;Halifax;NS;B3K 2Y5;Canada
>> email;internet:boutilpj at ednet.ns.ca
>> title:WAN Communications Specialist
>> tel;work:902-424-6800
>> tel;fax:902-424-0874
>> version:2.1
>> end:vcard
>>
> 
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> 
> 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: boutilpj.vcf
Type: text/x-vcard
Size: 286 bytes
Desc: not available
URL: <http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20200221/029c8122/attachment-0001.vcf>


More information about the Linux-PowerEdge mailing list