[Linux-PowerEdge] DSU on RHEL8 is asking for libssh2.so.1

Patrick Boutilier boutilpj at ednet.ns.ca
Tue Feb 4 06:39:48 CST 2020


[EXTERNAL EMAIL] 

On 2/4/20 3:04 AM, Andrea Gelmini wrote:
> On Tue, Feb 04, 2020 at 02:46:08PM +0800, Anthony Alba wrote:
>>
>> In order to work, one needs to copy libssh2.so.1 from a RHEL7 installation.
> 
> Yep, they (Red Hat) decided to remove libssh2 for security reason, in 8.1.
> 
> In my setup script for Dell environment what I do is:
> yum install -y 'http://mirror.centos.org/centos/7/os/x86_64/Packages/libssh2-1.8.0-3.el7.x86_64.rpm'
> 
> It's not a perfect solution, but it works.

Or just make a symbolic link.

cd /usr/lib64
ln -s libssh.so.4 libssh2.so.1



> 
> Ciao,
> Gelma
> 
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: boutilpj.vcf
Type: text/x-vcard
Size: 286 bytes
Desc: not available
URL: <http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20200204/2e0689f1/attachment-0001.vcf>


More information about the Linux-PowerEdge mailing list