[Linux-PowerEdge] dsu -- cannot parse inventory....

Spike_White at Dell.com Spike_White at Dell.com
Fri Dec 9 15:22:38 CST 2016


Dell - Internal Use - Confidential
Dsu is giving a weird error now on a M630 - says "could not parse the inventory".

[root at ausplpdb01 etc]# dsu
Verifying catalog installation ...
Installing catalog from repository ...
Fetching dsucatalog ...
Reading the catalog ...
Verifying inventory collector installation ...
Getting System Inventory ...
Could not parse the inventory

Per this:
http://lists.us.dell.com/pipermail/linux-poweredge/2016-October/050796.html

I found and ran /usr/libexec/dell_dup/invcol_7RMG4_LN64_16.10.200.816_A00

Output is below;  I'm just not sure what this is telling me.

[root at ausplpdb01 etc]# ls -l /usr/libexec/dell_dup
total 103244
-rwxr-xr-x 1 root root  6561164 Nov  8 00:52 Catalog.xml
drwxr-xr-x 2 root root       20 Dec  9 12:48 dell_ie_backplane
drwxr-xr-x 2 root root       20 Dec  9 12:48 dell_ie_bios
drwxr-xr-x 3 root root       31 Dec  9 12:48 dell_ie_idrac7
drwxr-xr-x 2 root root       20 Dec  9 12:48 dell_ie_maser_ic
drwxr-xr-x 3 root root     4096 Mar 17  2016 dell_ie_nic_emulex-1.1.0
drwxr-xr-x 2 root root       21 Dec  9 12:48 dell_ie_nic_intel-1.1.0
drwxr-xr-x 2 root root       20 Dec  9 12:48 dell_ie_nvme_pcissd
drwxr-xr-x 2 root root       20 Dec  9 12:48 dell_ie_pcissd
drwxr-xr-x 2 root root       20 Dec  9 12:48 dell_ie_ps
drwxr-xr-x 2 root root       36 Dec  9 12:48 dell_ie_sas
lrwxrwxrwx 1 root root       24 Mar 10  2016 EMULEX_FRMW -> dell_ie_nic_emulex-1.1.0
-rwxr-xr-x 1 root root 99154689 Nov  8 00:52 invcol_7RMG4_LN64_16.10.200.816_A00
lrwxrwxrwx 1 root root       18 Mar 10  2016 Tape_IBM -> dell_ie_tape_ibm-*
lrwxrwxrwx 1 root root       22 Mar 10  2016 Tape_Quantum -> dell_ie_tape_quantum-*
[root at ausplpdb01 etc]# ls -l /usr/libexec/dell_dup/invcol_7RMG4_LN64_16.10.200.816_A00
-rwxr-xr-x 1 root root 99154689 Nov  8 00:52 /usr/libexec/dell_dup/invcol_7RMG4_LN64_16.10.200.816_A00
[root at ausplpdb01 etc]# /usr/libexec/dell_dup/invcol_7RMG4_LN64_16.10.200.816_A00
<?xml version="1.0" encoding="UTF-8"?>


<SVMInventory lang="en" schemaVersion="1.0" invcolVersion="16.10.200 (BLD_816)" invcolBuild="816" timeStamp="2016-12-09T15:10:14">
        <OperatingSystem osCode="LIN" osVendor="Redhat" osArch="x64" majorVersion="redhat-release-server-7.2" minorVersion="3.10.0-123.13.2.el7.x86_64"/>
        <System systemID="060E"/><Device componentID="2331" display="OpenManage Server Administrator">
<Application componentType="APP" version="8.4.0" display="OpenManage Server Administrator"/>
</Device>
        <Device componentID="159" display="BIOS"><Application componentType="BIOS" version="1.4.5" display="BIOS"/></Device>
        <Device vendorID="1000" deviceID="005d" subDeviceID="1f48" subVendorID="1028" bus="2" device="0" function="0" display="PERC H730P Mini Controller 0"><Application componentType="FRMW" version="25.3.0.0016" display="PERC H730P Mini Controller 0 Firmware"/></Device>
        <Device componentID="103538" enum="CtrlId 0 DeviceId 0" display="ST600MM0088"><Application componentType="FRMW" version="TT31" display="Firmware for  - Disk 0 in Backplane 1 of PERC H730P Mini Controller 0  "/></Device>
        <Device componentID="103538" enum="CtrlId 0 DeviceId 1" display="ST600MM0088"><Application componentType="FRMW" version="TT31" display="Firmware for  - Disk 1 in Backplane 1 of PERC H730P Mini Controller 0  "/></Device>
        <Device componentID="25227" display=" iDRAC">
      <Application componentType="FRMW" version="2.21.21.21" display=" iDRAC"/>
   </Device>
        <Device vendorID="8086" deviceID="10F8" subVendorID="1028" subDeviceID="1F63" bus="1" device="0" function="0" display="Intel(R) Ethernet 10G 2P X520-k bNDC">
                <Application componentType="FRMW" version="17.0.12" display="Intel(R) Ethernet 10G 2P X520-k bNDC"/>
        </Device>
        <Device vendorID="8086" deviceID="10F8" subVendorID="1028" subDeviceID="1F63" bus="1" device="0" function="1" display="Intel(R) Ethernet 10G 2P X520-k bNDC">
                <Application componentType="FRMW" version="17.0.12" display="Intel(R) Ethernet 10G 2P X520-k bNDC"/>
        </Device>
        <Device vendorID="8086" deviceID="10F8" subVendorID="8086" subDeviceID="000C" bus="3" device="0" function="0" display="Intel(R) Ethernet X520 10GbE Dual Port KX4-KR Mezz">
                <Application componentType="FRMW" version="17.0.12" display="Intel(R) Ethernet X520 10GbE Dual Port KX4-KR Mezz"/>
        </Device>
        <Device vendorID="8086" deviceID="10F8" subVendorID="8086" subDeviceID="000C" bus="3" device="0" function="1" display="Intel(R) Ethernet X520 10GbE Dual Port KX4-KR Mezz">
                <Application componentType="FRMW" version="17.0.12" display="Intel(R) Ethernet X520 10GbE Dual Port KX4-KR Mezz"/>
        </Device>
        <Device vendorID="10DF" deviceID="F100" subDeviceID="F126" subVendorID="10DF" bus="4" device="0" function="0" wwpn="10000090FAC3A160" display="Emulex LPe1205-M 8Gb 2-port PCIe Fibre Channel Adapter">
        <Application componentType="FRMW" version="00.00.00" elxFwVer="UF201A10" display="Emulex LPe1205-M 8Gb 2-port PCIe Fibre Channel Adapter"/>
        <Application componentType="BIOS" version="00.00.00" elxBcVer="UU603X1" display="Emulex LPe1205-M 8Gb 2-port PCIe Fibre Channel Adapter"/>
    </Device>
        <Device vendorID="10DF" deviceID="F100" subDeviceID="F126" subVendorID="10DF" bus="4" device="0" function="1" wwpn="10000090FAC3A161" display="Emulex LPe1205-M 8Gb 2-port PCIe Fibre Channel Adapter">
        <Application componentType="FRMW" version="00.00.00" elxFwVer="UF201A10" display="Emulex LPe1205-M 8Gb 2-port PCIe Fibre Channel Adapter"/>
        <Application componentType="BIOS" version="00.00.00" elxBcVer="UU603X1" display="Emulex LPe1205-M 8Gb 2-port PCIe Fibre Channel Adapter"/>
    </Device>
        <Device componentID="101434" display="13G SEP Firmware" enum="Bay ID =1"><Application componentType="FRMW" version="2.23" display="13G SEP Firmware, BayID: 1"/></Device>
        </SVMInventory>


<?xml version="1.0" encoding="UTF-8"?>
<InventoryError lang="en"><SPStatus result="false" module="MaserIE -i"><Message> Inventory Failure: Unified Server Configurator  Failure - Detach USC failure - Detaching a partition has failed</Message></SPStatus><SPStatus result="false" module="MaserIE -i"><Message>Invalid inventory results.</Message></SPStatus></InventoryError>
[root at ausplpdb01 etc]#
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20161209/26aa5385/attachment.html 


More information about the Linux-PowerEdge mailing list